البداية / مايكروتك / الوينبوكس / ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email خطوة بخطوة

ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email خطوة بخطوة

ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email

يستخدم MikroTik Router بشعبية في شبكات مزودي خدمات الإنترنت وليس فقط شبكة المكاتب.

لذلك ، يجب على مسؤولي الشبكة تعلم كيفية الحفاظ على جهاز التوجيه MikroTik ومتابعتة بشكل صحيح.

حيث والمهمة العادية لمسؤول الشبكة هي تخزين نسخ احتياطية من ملف التكوين.

تقريبا كل مسؤول شبكة يعمل النسخ الاحتياطي لملف التكوين يدويا.

ولكن جهاز التوجيه MikroTik يوفر أداة بريد إلكتروني يمكن لمديري الشبكات من خلالها إجراء نسخ احتياطي لملف التكوين بشكل منتظم عبر البريد الإلكتروني

ويمكنه التخفيف من مهمه النسخ اليومي بسهولة.

علما انه لا يتم تكوين أداة البريد الإلكتروني بشكل افتراضي في جهاز التوجيه MikroTik.

لذلك ، يجب على مسؤولي الشبكة تكوين أداة البريد الإلكتروني وكذلك بعض البرامج النصية للحصول على خدمة النسخ الاحتياطي عبر البريد الإلكتروني.

اذا في هذه المقالة ، سأوضح لكم كيفية تكوين أداة البريد الإلكتروني MikroTik للحصول على نسخة احتياطية لملف التكوين عبر البريد الإلكتروني في بضع خطوات.

ارسال نسخة الباك اب للميكروتك الى الايميل

الآن سنقوم بتكوين أداة البريد الإلكتروني MikroTik بحيث يمكن إرسال نسخة احتياطية لملف التكوين عبر البريد الإلكتروني. يمكن تقسيم التكوين الكامل لتخزين النسخ الاحتياطي والإرسال عبر البريد الإلكتروني إلى 3 خطوات :-

  1. تكوين البريد الإلكتروني
  2. كتابة سيناريو  :mrgreen: لتخزين النسخ الاحتياطي وإرسال البريد الإلكتروني
  3. إنشاء جدولة scheduler  لتنفيذ البرنامج النصي script بانتظام

الخطوة 1: تكوين البريد الإلكتروني لـ MikroTik Router

لإرسال البريد الإلكتروني من جهاز التوجيه MikroTik ، نحتاج أولاً إلى تكوين البريد الإلكتروني للمرسل. ليس لدى MikroTik خادم SMTP. لهذا ، يتعين علينا توفير خادم SMTP وكذلك اسم المستخدم وكلمة المرور بحيث يمكن لجهاز التوجيه MikroTik إرسال البريد من خلال هذا الخادم SMTP.

لذلك ، لإعداد خادم SMTP واسم المستخدم وكلمة المرور في جهاز التوجيه MikroTik الخاص بك ، اتبع الخطوات التالية بعناية :-

  • انتقل إلى Tools > Email وقدم معلومات البريد الإلكتروني للمرسل على النحو التالي:
    Server: عنوان IP لخادم SMTP (استخدم عنوان IP لخادم البريد الخاص بك أو حاول استخدام عنوان IP الخاص بـ Gmail: 173.194.77.108)
    Port: منفذ خادم SMTP (عادةً 25 أو إذا كنت تستخدم Gmail SMTP ، استخدم 587)
    From: ضع عنوان البريد الإلكتروني الخاص بك .
    User: ضع اسم مستخدم البريد الإلكتروني (الجزء الأول من علامة @) أو عنوان البريد الإلكتروني الكامل إن أمكن.
    Password: ضع كلمة مرور البريد الإلكتروني الخاصة بك.
  • بدلا من ذلك ، يمكنك القيام أدناه باستخدام CMD:
    /tool e-mail
    set address=173.194.77.108
    set port=587
    set [email protected]
    set user= systemzonedotnet
    set password=*******
    حيث 173.194.77.108 هو Gmail SMTP Server IP ، [email protected] هو معرف بريد اختبار تم إنشاؤه لهذه المقالة و “*******” هو كلمة المرور. 
  • للتحقق من تكوين البريد الإلكتروني ، أرسل بريدًا تجريبيًا من MikroTik
    <//tool e-mail send [email protected] subject=”email test” body=”email test” tls=yesli>

إذا كان كل شيء على ما يرام ، فسيتم إرسال البريد الإلكتروني التجريبي إلى عنوان البريد الإلكتروني للمستلم. اكتمل إعداد البريد الإلكتروني إذا اتبعت الخطوات المذكورة أعلاه بعناية. الآن سنكتب البرنامج النصي لتخزين ملف النسخ الاحتياطي وإرساله عبر البريد.

الخطوة 2: السيناريو لتخزين ملف النسخ الاحتياطي وإرساله عبر البريد الإلكتروني :

بعد إكمال تكوين البريد الإلكتروني ، سنقوم بكتابة برنامج نصي يقوم بتخزين ملف النسخ الاحتياطي ثم يرسل ملف النسخة الاحتياطية إلى عنوان البريد المطلوب.

اتبع الخطوات أدناه لكتابة البرنامج النصي اي السكربت في جهاز التوجيه MikroTik الخاص بك :-

  • انتقل إلى System> Scripts وانقر فوق (+) لإضافة نص جديد. سوف تظهر نافذة البرنامج النصي الجديد.
  • اكتب اسم البرنامج النصي الخاص بك (على سبيل المثال ، نسخ احتياطي للبريد) في مربع إدخال الاسم ، ثم قم بنسخ ولصق التعليمة البرمجية ( السكربت ) أدناه في المربع ::log info “Mikrotik Backup JOB Started . . . “
    :global backupfile configbackup
    :log info “Deleting old Backup File If available otherwise ignore & process further . . . “
    /system backup save name=$backupfile
    :log info “Backup process pausing for 10s so it complete creating backup file”
    :delay 10s
    :log info “Start Sending Backup File via Email using GMAIL SMTP . . .” tool e-mailsend [email protected] subject=([/system clock get date] . \ ” MikroTik Backup”) body=”MikroTik email Backup” tls=yes file=$backupfile
    :delay 40s
    :log info “Backup Finished”
    :log info “Deleting Backup File. All Done.”
    /file remove $backupfile
  • الآن انقر فوق الزر “تطبيق” و “موافق” لحفظ هذا السكربت.
  • يمكنك تشغيل هذا البرنامج النصي يدويًا بالنقر فوق زر Run Script

اصبح السكربتالخاص بتخزين ملف النسخ الاحتياطي للتكوين وإرسال الملف عبر البريد الإلكتروني جاهز الآن. الآن سنقوم بإنشاء جدولة بحيث يمكن تشغيل هذا السكربت بانتظام في وقت محدد.

الخطوة 3: جدولة تنفيذ الـ Script بانتظام :

لقد أنشأنا بسكربت لتخزين التكوين وإرساله عبر البريد. لكن هذا السكربت لا يستطيع تنفيذ نفسه. لذا ، يتعين علينا إنشاء جدولة لتنفيذ البرنامج النصي أعلاه بشكل منتظم في الوقت المطلوب.

ولإنشاء هذة الجدولة في جهاز التوجيه MikroTik ، اتبع الخطوات أدناه :

  • انتقل إلى System> Scheduler وانقر على  (+) لإضافة برنامج جدولة جديد.
  • اكتب اسم للجدولة في مربع إدخال الاسم وضع وقت تنفيذ السكربت في مربع إدخال وقت البدء. على سبيل المثال ، إذا كنت تريد تنفيذ السكربت في الساعة 5:30 مساءً ، فضع الوقت 17:30:00.
    backup via mikrotik
  • ضع الفاصل الزمني Interval في حقل الإدخال الفاصل. على سبيل المثال ، إذا كنت تريد تنفيذ النص البرمجي يوميًا ، فضع القيمة على النحو 24:00:00
  • الآن ضع اسم البرنامج النصي الخاص بك الذي قمت بتوفيره في الخطوة 2 (هنا ، Mail Backup) في المربع تحت  On Event، ثم انقر فوق الزر تطبيق و موافق.

الجدولة جاهزة الآن. إذا كان كل شيء على ما يرام ، سيقوم جهاز MikroTik Router بإرسال البريد إلكتروني بانتظام إلى عنوان البريد الإلكتروني المطلوب حيث يجب أن يكون ملف التكوين مرفقًا به.

ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم بعنوان ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email

اذا اعجبك الموضوع ارسال نسخة الباك اب للميكروتك الى الايميل Backup via Email لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة… حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager تمكين المستخدمين المحددين تسجيل الدخول …



Mohon Aktifkan Javascript!Enable JavaScript