البداية / مايكروتك / الوينبوكس / الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

portal-routing-in-pcc

إخلاء المسؤولية:

أتلقى العديد من رسائل البريد الإلكتروني من المشغلين المحليين حول كيفية الوصول إلى بوابة مشاركة الوسائط لمشغلي الشبكات الآخرين بحيث يمكن للمستخدمين المحليين الوصول إليها.

بدلاً من ذلك ، رد كل واحد على حدة & بسبب نقص الوقت ، سأنشر طريقة بسيطة توضح كيف يمكنك السماح للمستخدمين الخاصين بك الوصول إلى بوابة الوسائط الخارجية المشغله عبر load balance mikrotik.

يوصى بشدة بالبحث أولاً عن موقع الويب / الخوادم المستهدفة على الويب باستخدام مسار التتبع أو wire shark. يجب عليك إجراء التتبع الطويل عن طريق محاولة الاتصال بموقع الويب المستهدف أولاً ثم البدء في تنزيل ملفات متعددة ، باستخدام إما TORCH ، أو استخدام WIRE SHARK ، ويمكنك الحصول على ips لجميع الخوادم التي يتم الوصول إليها من خلال التورنت / idm الذي يربط بين الخدمات المستهدفة.

تم نشر مثال WIRESHARK bellow….

الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer - بوابة الوسائط الخارجية

سيناريو:-

نحن نستخدم Mikrotik كخادم pppoe ووصلات vdsl المزدوجة كموازن تحميل WAN. لقد حصلنا على خط مشغل X آخر فقط للوصول إلى بوابة الترفيه التي تعتبر رائعة في ملفات مشاركة الوسائط بما في ذلك ألعاب الفيديو وما إلى ذلك.

نريد أن نسمح لمستخدمنا بالدخول إلى البوابة باستخدام mikrotik دون التدخل في أي شبكة أخرى.

الحل:-

طريقة سريعة ولاكن يجب عليك تحسينه عند النشر في بيئة الإنتاج.

قمنا بتكوين جهاز راوتر واي فاي بسيط جنبا إلى جنب مع خدمة المشغل X في ذلك.

الآن قم بتوصيل هذا الخط LAN الموجه في mikrotik الخاص بك (على سبيل المثال Port 12).

خطة IP:

  • Mikrotik LAN IP for pppoe users : eth0 > 192.168.0.1
  • Mikrotik PPPoE IP series (allowed users for internet) : 192.168.200.0/24
  • Mikrotik WAN-1 IP Series for DSL1 : eth1 > 192.168.1.1
  • Mikrotik WAN-2 IP Series for DSL2 : eth2 > 192.168.2.1
  • Mikrotik eth12 IP Series for Portal X : eth12 > 192.168.12.2 ( > 192.168.12.1 is wifi router with local OP service)
  • PORTAL-X IP Series: Web Portal – 123.123.123.0/24  Download servers – 172.17.1.0/24

ملحوظة:-

بالنسبة لـ DNS ، يمكنك إما استخدام خوادم DNS OP-X (أو جهاز توجيه wifi كجهاز dns الخاص بك حيث سيحصل جهاز التوجيه اللاسلكي على DNS ديناميكيًا من OP-X ، أو يمكنك إنشاء إدخالات dns ثابتة في خادم dns mikrotik الخاص بك ، وتأكد من جميع العملاء يستخدمون mikrotik الخاص بك كما يوجد خادم DNS المفضل ، يمكنك أيضا إنشاء جهاز التوجيه القسري لإعادة توجيه جميع طلبات dns الصادرة إلى mirkotik الخاص بك.ما هو أسهل بالنسبة لك 🙂

# PPPoE Users IP List to access internet/portal
/ip firewall address-list
add address=192.168.200.0/24 comment="Allowed Users to Use Internet" list="allowed users"
# Add Portal X IP Series, you can get there list by inspecting torrent files, or using WIRESHARK
add address=123.123.123.0/24 list=portalx_list
add address=172.17.1.0/24 list=portalx_list
 
# Accept the PORTAL X packets to avoid processing them in PCC, then using routes we can route them via wifi router
/ip firewall mangle
add action=accept chain=prerouting comment="ACCEPT portalx_list PACKETS FROM PROCESSING THEM IN PCC - ZAIB" dst-address-list=portalx_list src-address-list="pppoe_allowed_users"
 
# Allow requests going to Portal X interface (to wifi router with OP X service)
/ip firewall nat
add action=masquerade chain=srcnat comment=ALLOW_ACCESS_TO_portalx_list_INTERFACE out-interface=eth12 src-address-list="pppoe_allowed_users
 
# Since we have excluded the Portal.X from PCC, therefor we have to create ROUTE for these packets
# So that these packets should route via Wi.Fi Router (connected with OP X service)
/ip route
add distance=1 dst-address=123.123.123.0/24 gateway=192.168.12.1 comment=route_for_portalx_site_going_via_local_wifi_router
add distance=1 dst-address=172.17.1.0/24 gateway=192.168.12.1 comment=route_for_portalx_site_going_via_local_wifi_router
 
# In the end , simply create QUEUE to allow more bandwidth going to Portal X servers,
# Again, if you had used packet marking, then you can use marked pkts & use single queue, more efficient
/queue simple
add max-limit=1G/1G name="portalx_list.torrent queue-1G" target=172.17.17.0/24
add max-limit=1G/1G name=portalx_list-public-ips-1G target=123.123.123.0/24

أنتهى … الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع الوصول إلى بوابة OP أخرى عبر Mikrotik Load Balancer – بوابة الوسائط الخارجية لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager تمكين المستخدمين المحددين تسجيل الدخول …



Mohon Aktifkan Javascript!Enable JavaScript