البداية / مايكروتك / مشاكل وحلول / تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

هنالك ممن يشتكي من عدم انتهاء صلاحية الكروت في نظام الهوتسبوت وهو الذي يختلف عن اليوزر مانجر

واليوم سنتحدث عن حل لهذي المشكلة بإتباع الخطوات التالية :

نقوم بتحديد صلاحية الكروت لمستخدمين الـ hotspot حيث نقوم بالذهاب الى قائمه الـ IP ثم user profile ونختار نافذة الـ scripts ونعمل لصق لهذا الكود كما في الصوره ادناه :

{:local date [ /system clock get date ];:if ( [ /ip hotspot user get $user comment ] = "" ) do={[ /ip hotspot user set $user comment=$date ];}}

تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

اذا كان لديك اسم البروفايل مثلا 3h نقوم بعمل نسخ لصق لهذا الامر في النيو ترمنال

وسوف يقوم بالتأكد من اسم الباقه اذا كانت فعلا 3h حيث سيقوم  بعمل صلاحيه لها 3 ساعات بصلاحية ثلاث ايام وبسعر 100 ريال :

 /ip hotspot user  set [find where limit-uptime=3h] [email protected]_100.ptd
 واذا كان لديك مثلا باقه 4 ساعات ستقوم بكتابة هذا الامر ولصقه في النيوترمنال :
 /ip hotspot user  set [find where limit-uptime=4h] [email protected]_200.ptd

صلاحية الكروت في الوهتسبوت

تحديد صلاحية الكروت في الهوتسبوت

الان نقوم بإضافة اسكربت وسنعطية أسم  مثلا disable_end_users كما في الصوره ادناه :

كروت الهوتسبوت hotspot

الان

قم بعمل نسخ لصق لهذا الاسكربت في نافذه الـ source :
 {:global today;{:local date [ /system clock get date ];:local montharray ( "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec" );:local monthdays ( 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 );:local days [ :pick $date 4 6 ];:local monthtxt [ :pick $date 0 3 ];:local year [ :pick $date 7 11 ];:local months ([ :find $montharray $monthtxt]);:for nodays from=0 to=$months do={:set days ( $days + [ :pick $monthdays $nodays ] )};:set days ($days + $year * 365);:set today $days;};:foreach i in [ /ip hotspot user find where disabled=no ] do={:if ([ :find [ /ip hotspot user get $i comment ] ] = 0 && [ :find [ /ip hotspot user get $i email ] ] = 0) do={:local date [ /ip hotspot user get $i comment ];:local oldemail [ /ip hotspot user get $i email ];:local atmark [ :find $oldemail "@" ];:local dotmark [ :find $oldemail "." ];:if ( $atmark >= 0 && $dotmark >= 0 ) do={:local validity [ :pick $oldemail 0 $atmark];:local rest [ :pick $oldemail ($atmark + 1) [ :len $oldemail] ];:if ( [:tonum $validity] != "" ) do={:if ( [:tonum $validity] != "0" ) do={:local montharray ( "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec" );:local monthdays ( 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 );:local days [ :pick $date 4 6 ];:local monthtxt [ :pick $date 0 3 ];:local year [ :pick $date 7 11 ];:local months ( [ :find $montharray $monthtxt ] );:for nodays from=0 to=$months do={:set days ( $days + [ :pick $monthdays $nodays ] )};:set days ($days + $year * 365);:if ( ($days + $validity) < $today ) do={ :local name [/ip hotspot user get $i name];:log info "HOTSPOT VALITITY EXPIRE: Disabling Hotspot user $name first logged in $date";[ /ip hotspot user disable $i ];}}}}}}}

الان نعمل إضافة لتشغيل هذا الاسكربت :

تشغيل الاسكربت كل فتره زمنية معينه مثلا كل 3 ساعات او حسب رغبتك

وسيقوم هذا الاسكولدر بتشغيل الاسكربت الذي ضفته سابقا disable_end_users ونضيف فية هذا الكود التالي كما في الصورة ادناة :

 / system script run disable_end_users

hotspot account mikrotik user

أنتهى … تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع تحديد صلاحيات الكروت في الهوتسبوت في سيرفر الميكروتك للكروت المنتهية لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

Blocking WhatsApp in Mikrotik

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة التحديثات: قد لا يعمل …



Mohon Aktifkan Javascript!Enable JavaScript