البداية / مايكروتك / مشاكل وحلول / حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

التحديثات: قد لا يعمل هذا الدليل بعد أن انتقلت ال WhatsApp إلى ip pool لمجمع فيسبوك. كما هو مذكور هنا.

(قد لا يزال بإمكانك حظر تطبيق whatsapp باستخدام سكربت لالتقاط ال ip الخاص بـ whatsapp فقط والذي قد يستغرق بعض الوقت للقبض على جميع عناوين IP ذات الصلة ولكن ربما يتم حظر بعض المحتويات الأخرى أيضًا. تحتاج إلى القيام بفحص عميق في هذا الصدد. أنا قدمت هذه المشاركة لأغراض مرجعية فقط)

اعزائي ،

يرجى ملاحظة أننا قمنا بترحيل أحدث IP pools من WhatsApp إلى Facebook Partner Portal. لا تتردد في التصفح إلى صفحة الإعدادات الخاصة بالبوابة وتنزيل أحدث إصدار من WhatsApp IP pool: https://fb.me/mpp_support
كما يتم إجراء تحديثات إضافية لمجموعات IP من خلال البوابة ولم تعد موزعة عبر البريد الإلكتروني أو عبر موقع WhatsApp على الويب.


إذا لم تكن مسجلاً بعد في Portal Partner Portal أو واجهتك صعوبات في الوصول إليه – يرجى طلب الوصول من خلال النموذج التالي : https://fb.me/mpp_access
لأي طلبات فنية ، يرجى الاتصال من خلال قسم الدعم في البوابة: https://fb.me/mpp_support
فريق ال WhatsApp

من أجل منع تطبيق WhatsAPP في Mikrotik ، استخدمت WhatsAPP قائمة العناوين المقدمة [167 عنوان IPV4 اعتبارًا من يونيو 2017] من أجل حظر التطبيق.

[هناك بالفعل العديد من الأدلة على الإنترنت ، لكنني استخدمت طريقة المدرسة القديمة لمنع هذا التطبيق وحصلت على النجاح!]. يرجى الحذر من أنه إذا كان المستخدم يستخدم vpn ، فإن هذا التقييد لن يكون فعالاً.

أنا أشارك طريقتين لتحقيق نفس الهدف. هناك أيضًا طريقة أخرى تقوم فيها بتحويل حركة مرور المستخدمين dns إلى dns mikrotik الخاص بك واستخدام السكربت لجلب عناوين IP المقترنة بأي عنوان URL يحتوي على whatsapp فيه ، لكني لا أقوم بمناقشته هنا في لحظة.

يمكنك أيضًا أتمتة هذه المهمة عن طريق جلب القائمة من whatsapp مباشرةً واستيرادها في قائمة العناوين ، بحيث يمكنك دائمًا تحديث قائمة خوادم whatsapp. على الرغم من أن القائمة لا يتم تحديثها بشكل متكرر إلا أنها لا تزال فكرة جيدة لأتمتتها باستخدام برنامج الجدولة scheduler .

1- قم بتنزيل whatsapp IP (CIDR) من القائمة :

https://www.whatsapp.com/cidr.txt

احفظه cidr.txt

ملاحظة: إذا لم يكن لديك ipv6 ، فقم بفتح هذا الملف وأزل كل عنوان IPV6 وإلا ستشاهد أدناه خطأ أثناء الاستيراد

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

2- قم بتحميل ملف cidr.txt هذا إلى قسم Mikrotik FILES :

[إذا كنت تستخدم طريقة الجلب لتنزيل الملف مباشرة إلى mikrotik ، فأنت لا تحتاج إلى تحميل ملف يدوي ، لكنني استخدمت هذه الطريقة لأن معظم الشبكات المحلية تعمل على ipv4 ، لذلك اضطررت إلى إزالة إدخالات ipv6 أولاً من أجل استيراد القائمة)

cidr

3-استيراد محتويات الملف (الذي يتضمن عناوين IP) باستخدام السكربت التالي. يمكنك ببساطة نالسخ واللصق. تأكد من اسم الملف الصحيح فيه.

{
:local content [/file get [/file find name=cidr.txt] contents]
:local contentLen [:len $content]
:local lineEnd 0
:local line ""
:local lastEnd 0
:while ($lineEnd < $contentLen) do={
:set lineEnd [:find $content "\r\n" $lastEnd]
:if ([:len $lineEnd] = 0) do={
:set lineEnd $contentLen
}
:set line [:pick $content $lastEnd $lineEnd]
:set lastEnd ($lineEnd + 2)
/ip firewall address-list add list="whatsapp_list" address=$line
}
}

إذا نجحت ، سترى قائمة العناوين على النحو التالي [167 مدخلة حاليًا] …

whtsapp-address-list

4- إنشاء Firewall Filter rule لحظر الطلبات التي تذهب إلى whatsapp_list :

/ip firewall filter
add action=drop chain=forward comment="Block Whatsapp address list - zaib" disabled=yes dst-address-list=whatsapp_list

النتيجة :

block-whatapp-result

تم .

الطريقة الثانية – أسلوبالنسخ و اللصق باستخدام حزمة ipV4 فقط :

فتح النيوترمنال ونسخ لصق بعد التعليمات البرمجية. سيضيف اسم قائمة العناوين “whatsapp_list” جنبًا إلى جنب مع قاعدة جدار الحماية لحظر الطلبات التي تنتقل إلى هذه القائمة.

/ip firewall address-list
add address=31.13.64.51 list=whatsapp_list
add address=31.13.65.49 list=whatsapp_list
add address=31.13.66.49 list=whatsapp_list
add address=31.13.68.52 list=whatsapp_list
add address=31.13.69.240 list=whatsapp_list
add address=31.13.70.49 list=whatsapp_list
add address=31.13.71.49 list=whatsapp_list
add address=31.13.72.52 list=whatsapp_list
add address=31.13.73.49 list=whatsapp_list
add address=31.13.74.49 list=whatsapp_list
add address=31.13.75.52 list=whatsapp_list
add address=31.13.76.81 list=whatsapp_list
add address=31.13.77.49 list=whatsapp_list
add address=31.13.78.53 list=whatsapp_list
add address=31.13.80.53 list=whatsapp_list
add address=31.13.81.53 list=whatsapp_list
add address=31.13.82.51 list=whatsapp_list
add address=31.13.83.51 list=whatsapp_list
add address=31.13.84.51 list=whatsapp_list
add address=31.13.85.51 list=whatsapp_list
add address=31.13.86.51 list=whatsapp_list
add address=31.13.87.51 list=whatsapp_list
add address=31.13.88.49 list=whatsapp_list
add address=31.13.90.51 list=whatsapp_list
add address=31.13.91.51 list=whatsapp_list
add address=31.13.92.52 list=whatsapp_list
add address=31.13.93.51 list=whatsapp_list
add address=31.13.94.52 list=whatsapp_list
add address=31.13.95.63 list=whatsapp_list
add address=50.22.198.204/30 list=whatsapp_list
add address=50.22.210.32/30 list=whatsapp_list
add address=50.22.210.128/27 list=whatsapp_list
add address=50.22.225.64/27 list=whatsapp_list
add address=50.22.235.248/30 list=whatsapp_list
add address=50.22.240.160/27 list=whatsapp_list
add address=50.23.90.128/27 list=whatsapp_list
add address=50.97.57.128/27 list=whatsapp_list
add address=75.126.39.32/27 list=whatsapp_list
add address=108.168.174.0/27 list=whatsapp_list
add address=108.168.176.192/26 list=whatsapp_list
add address=108.168.177.0/27 list=whatsapp_list
add address=108.168.180.96/27 list=whatsapp_list
add address=108.168.254.65 list=whatsapp_list
add address=108.168.255.224 list=whatsapp_list
add address=108.168.255.227 list=whatsapp_list
add address=157.240.0.53 list=whatsapp_list
add address=157.240.1.53 list=whatsapp_list
add address=157.240.2.53 list=whatsapp_list
add address=157.240.3.53 list=whatsapp_list
add address=157.240.6.53 list=whatsapp_list
add address=157.240.7.54 list=whatsapp_list
add address=157.240.8.53 list=whatsapp_list
add address=157.240.9.53 list=whatsapp_list
add address=157.240.10.53 list=whatsapp_list
add address=157.240.11.53 list=whatsapp_list
add address=157.240.12.53 list=whatsapp_list
add address=157.240.13.54 list=whatsapp_list
add address=158.85.0.96/27 list=whatsapp_list
add address=158.85.5.192/27 list=whatsapp_list
add address=158.85.46.128/27 list=whatsapp_list
add address=158.85.48.224/27 list=whatsapp_list
add address=158.85.58.0/25 list=whatsapp_list
add address=158.85.61.192/27 list=whatsapp_list
add address=158.85.224.160/27 list=whatsapp_list
add address=158.85.233.32/27 list=whatsapp_list
add address=158.85.249.128/27 list=whatsapp_list
add address=158.85.254.64/27 list=whatsapp_list
add address=169.44.23.192/27 list=whatsapp_list
add address=169.44.36.0/25 list=whatsapp_list
add address=169.44.57.64/27 list=whatsapp_list
add address=169.44.58.64/27 list=whatsapp_list
add address=169.44.80.0/26 list=whatsapp_list
add address=169.44.82.96/27 list=whatsapp_list
add address=169.44.82.128/27 list=whatsapp_list
add address=169.44.82.192/26 list=whatsapp_list
add address=169.44.83.0/26 list=whatsapp_list
add address=169.44.83.96/27 list=whatsapp_list
add address=169.44.83.128/27 list=whatsapp_list
add address=169.44.83.192/26 list=whatsapp_list
add address=169.44.84.0/24 list=whatsapp_list
add address=169.44.85.64/27 list=whatsapp_list
add address=169.44.87.160/27 list=whatsapp_list
add address=169.44.167.0/27 list=whatsapp_list
add address=169.45.71.32/27 list=whatsapp_list
add address=169.45.71.96/27 list=whatsapp_list
add address=169.45.87.128/26 list=whatsapp_list
add address=169.45.169.192/27 list=whatsapp_list
add address=169.45.182.96/27 list=whatsapp_list
add address=169.45.210.64/27 list=whatsapp_list
add address=169.45.214.224/27 list=whatsapp_list
add address=169.45.219.224/27 list=whatsapp_list
add address=169.45.237.192/27 list=whatsapp_list
add address=169.45.238.32/27 list=whatsapp_list
add address=169.45.248.96/27 list=whatsapp_list
add address=169.45.248.160/27 list=whatsapp_list
add address=169.46.52.224/27 list=whatsapp_list
add address=169.46.111.144/28 list=whatsapp_list
add address=169.47.5.192/26 list=whatsapp_list
add address=169.47.6.64/27 list=whatsapp_list
add address=169.47.33.128/27 list=whatsapp_list
add address=169.47.35.32/27 list=whatsapp_list
add address=169.47.37.128/27 list=whatsapp_list
add address=169.47.40.128/27 list=whatsapp_list
add address=169.47.42.96/27 list=whatsapp_list
add address=169.47.42.160/27 list=whatsapp_list
add address=169.47.42.192/26 list=whatsapp_list
add address=169.47.47.160/27 list=whatsapp_list
add address=169.47.130.96/27 list=whatsapp_list
add address=169.47.192.192/27 list=whatsapp_list
add address=169.47.194.128/27 list=whatsapp_list
add address=169.47.198.128/27 list=whatsapp_list
add address=169.47.212.160/27 list=whatsapp_list
add address=169.53.29.128/27 list=whatsapp_list
add address=169.53.48.32/27 list=whatsapp_list
add address=169.53.71.224/27 list=whatsapp_list
add address=169.53.81.64/27 list=whatsapp_list
add address=169.53.250.128/26 list=whatsapp_list
add address=169.53.252.64/27 list=whatsapp_list
add address=169.53.255.64/27 list=whatsapp_list
add address=169.54.2.160/27 list=whatsapp_list
add address=169.54.44.224/27 list=whatsapp_list
add address=169.54.51.32/27 list=whatsapp_list
add address=169.54.55.192/27 list=whatsapp_list
add address=169.54.193.160/27 list=whatsapp_list
add address=169.54.210.0/27 list=whatsapp_list
add address=169.54.222.128/27 list=whatsapp_list
add address=169.55.67.224/27 list=whatsapp_list
add address=169.55.69.128/26 list=whatsapp_list
add address=169.55.74.32/27 list=whatsapp_list
add address=169.55.75.96/27 list=whatsapp_list
add address=169.55.100.160/27 list=whatsapp_list
add address=169.55.126.64/26 list=whatsapp_list
add address=169.55.210.96/27 list=whatsapp_list
add address=169.55.235.160/27 list=whatsapp_list
add address=173.192.162.32/27 list=whatsapp_list
add address=173.192.219.128/27 list=whatsapp_list
add address=173.192.222.160/27 list=whatsapp_list
add address=173.192.231.32/27 list=whatsapp_list
add address=173.193.205.0/27 list=whatsapp_list
add address=173.193.230.96/27 list=whatsapp_list
add address=173.193.230.128/27 list=whatsapp_list
add address=173.193.230.192/27 list=whatsapp_list
add address=173.193.239.0/27 list=whatsapp_list
add address=174.36.208.128/27 list=whatsapp_list
add address=174.36.210.32/27 list=whatsapp_list
add address=174.36.251.192/27 list=whatsapp_list
add address=174.37.199.192/27 list=whatsapp_list
add address=174.37.217.64/27 list=whatsapp_list
add address=174.37.243.64/27 list=whatsapp_list
add address=174.37.251.0/27 list=whatsapp_list
add address=179.60.192.51 list=whatsapp_list
add address=179.60.195.51 list=whatsapp_list
add address=184.173.136.64/27 list=whatsapp_list
add address=184.173.147.32/27 list=whatsapp_list
add address=184.173.161.64 list=whatsapp_list
add address=184.173.173.116 list=whatsapp_list
add address=184.173.179.32/27 list=whatsapp_list
add address=185.60.216.53 list=whatsapp_list
add address=185.60.218.53 list=whatsapp_list
add address=185.60.219.53 list=whatsapp_list
add address=192.155.212.192/27 list=whatsapp_list
add address=198.11.193.182/31 list=whatsapp_list
add address=198.11.251.32/27 list=whatsapp_list
add address=198.23.80.0/27 list=whatsapp_list
add address=208.43.115.192/27 list=whatsapp_list
add address=208.43.117.79 list=whatsapp_list
add address=208.43.122.128/27 list=whatsapp_list
# Adding firewall rule to block whatsapp address list.
/ip firewall filter
add action=drop chain=forward comment="Block Whatsapp address list" dst-address-list=whatsapp_list

النتيجة :

block-whatapp-result

أنتهى … حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

MikroTik Hyper-V وحدة التحكم التسلسلية

MikroTik Hyper-V وحدة التحكم التسلسلية واستخدام برنامج PuTTY للوصول للواجهة التسلسلية

MikroTik Hyper-V وحدة التحكم التسلسلية واستخدام برنامج PuTTY للوصول للواجهة التسلسلية أفعل الكثير من العمل …



Mohon Aktifkan Javascript!Enable JavaScript