البداية / مايكروتك / مشاكل وحلول / حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

مقدمة :

كل شبكة مختلفة ، لذلك لا يمكن تطبيق حل واحد على الجميع. لذلك حاول فهم المنطق وإنشاء حل يمكن أن يتطابق مع سيناريو شبكتك. لا تتبع اسلوب النسخ واللصق بشكل أعمى.

سيناريو:

نحن نستخدم Mikrotik CCR كما PPPOE NAS. في جهاز توجيه مطابق للمزج حيث يتلقى عدد كبير من المستخدمين IP الخاص (عبر اتصال pppoe) ويتلقى جزء كبير آخر IP من Public pool الموجه كذلك.

مشكلة:-

عندما يكون لدينا انقطاع في الشبكة مثل الفشل في أي منطقة معينة للبث ، ففي LOG يمكننا رؤية العديد من جلسات PPPoE مفصولة برسائل “peer not responding“. بالضبط في هذه اللحظات ، يصل استخدام وحدة المعالجة المركزية NAS إلى 100٪ تقريبًا ، مما يؤدي إلى توقف جهاز الميكروتك عن مرور الـ traffic بأي نوع من أنواع الزيارات. وهذا يمكن أن تستمر لمدة دقيقة أو حتى أعلى.

كما هو موضح في الصورة أدناه …

pppoe high cpu usage

إذا كنت تستخدم Masquarade / NAT على جهاز router ، فهذه هي المشكلة. عند استخدام Masquarade ، يتعين على RouterOS إجراء إعادة حساب تتبع الاتصال الكامل على كل وصلة اتصال / قطع اتصال.

لذلك إذا كان لديك الكثير من جلسة PPP / الاتصال ، سيتم باستمرار إعادة حساب تتبع الاتصال الذي يمكن أن يسبب استخدام CPU عالي. عند اتصال / قطع الاتصال ، بالاشتراك مع NAT ، فإنه يمنحك استخدام CPU عالي.

الحل أو الحل ممكن :

إذا كان لديك الكثير من مستخدمي PPP مع بعض قواعد NATTING ، فتوقف عن استخدام Masquarade على نفس router الذي يحتوي على الكثير من الانترفيس الديناميكية. لا تستخدم NAT على أي جهاز router يحتوي على عدد كبير من انترفيس الاتصال / الفصل ، مثل pppoe / vpn. ضع جهاز router إضافي متصل بـ PPPoE NAS ، وقم بتوجيه NAT إلى هناك.

مثال: قم بإضافة جهاز router آخر وقم بتنفيذ جميع عمليات natting على ذلك الـ router عن طريق إرسال حركة traffic محددة من سلسلة ip الخاصة إلى جهاز router nat هذا. توجيه الإعداد بين PPPoE NAS وجهاز التوجيه NAT.

فيما يلي مثال عملي :

1 # CCR الرئيسية كـ PPPOE NAS

تفاصيل Interface :

  • ETHER1-LAN-: 192.168.88.1/24 <الواجهة المواجهة للمستخدم حيث تؤسس اتصالات pppoe
  • PUBLIC-WAN: 101.11.11.254 <WAN Interface لتوجيه IP العام
  • 2-NAT-ROUTER: 192.168.60.2/24 <واجهة متصلة بـ CCR آخر من أجل natting

PPPoE User IP Pool > 172.16.0.1-172.16.0.255
UPSTREAM ISP Core Router Gateway IP >  101.11.11.36

2 # CCR الثانية كموجه NATTING :

تفاصيل Interface :

  • 2-CCR-LAN: 192.168.60.1/24 <واجهة متصلة مع CCR الرئيسي [pppoe]
  • شبكة NATTING-WAN: 101.11.11.253 <واجهة لمستخدمي natting [حركة المرور القادمة من CCR الرئيسية من أجل natting]
  • UPSTREAM ISP Core Router Gateway IP >  101.11.11.36

1# Main CCR Configuration for marking traffic

أولاً سنضع علامة على حركة المرور private/public ip وسننشئ طرقًا لها أيضًا :

/ip firewall mangle
add action=mark-routing chain=prerouting comment="Mark routing for Private IP users - zaib" disabled=no new-routing-mark=nat_routing passthrough=yes src-address=172.16.0.1-172.16.0.255
# We really dont need to mark traffic for public ip's because they will simply pass from our default route , but just for the sake of demonstration we are doing it.
add action=mark-routing chain=prerouting comment="Mark routing for PUBLIC IP users - zaib" disabled=no new-routing-mark=p

تأكد من عدم وجود أي قواعد NAT في المكان. [في قسم NAT]

الآن أضف Routes للـ traffic :

/ip route
add comment="Route private ip traffic via second NAT router" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.100.1 routing-mark=nat_routing scope=30 target-scope=10
add comment="Route public ip via this router default Gateway" disabled=no distance=1 dst-address=0.0.0.0/0 gateway=101.11.11.36 routing-mark=public_routing scope=30 target-scope=10
# DEFAULT Gateway for router's own traffic - zaib
add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=101.11.11.36 scope=30 target-scope=10

يتم تكوين جزء CCR الرئيسي. أنتقل الآن نحو الراوتر الثاني حيث سيتم تنفيذ جميع عمليات NATTING .

2# NATTING CCR Configuration for Masquerade

قم أولاً بإنشاء قاعدة NAT الافتراضية [قد ترغب في إضافة سلسلة ip لأغراض الأمان.

/ip route
add comment="Default Router for NATTING router " disabled=no distance=1 dst-address=0.0.0.0/0 gateway=101.11.11.36 scope=30 target-scope=10
# Add reverse Route so that NATTING router can see the pppoe user directly
add disabled=no distance=1 dst-address=172.16.0.0/16 gateway=192.168.100.2 scope=30 target-scope=10

الاختبار :

  • إنشاء مستخدم TEST في CCR pppoe NAS الرئيسي
  • قم بتعيين profile ملف تعريف IP الخاص به
  • قم بتوصيل معرف الاختبار هذا من اختبار الكمبيوتر وتشغيل برنامج TRACEROUTE

شاهد الصور :

قم بتوصيل معرف الاختبار هذا من اختبار الكمبيوتر وتشغيل برنامج TRACEROUTE

nat-vs-route

RUN Torch على NATTING Router… كما يمكننا أن نرى أن NATTING الموجه يشاهد مستخدمي pppoe dueto مباشرة في الاتجاه المعاكس.

حل مشكلة الميكروتك - peer not responding

أنتهى … حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع حل مشكلة الميكروتك – peer not responding – فصل NATTING عن التوجيه في Mikrotik لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

Blocking WhatsApp in Mikrotik

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة

حظر تطبيق الواتساب في الميكروتك ومنع استخدامة من قبل المتصلين بالشبكة التحديثات: قد لا يعمل …



Mohon Aktifkan Javascript!Enable JavaScript