البداية / مايكروتك / مشاكل وحلول / عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

يمكن أن تتسبب الأجهزة الغريبة الموجودة على الشبكة في حدوث مشكلات خطيرة في العمليات والأمان المستمر.

حيث من الممكن استخدام جهاز غير مصرح به يقوم بتشغيل خادم DHCP لاختطاف العملاء المحليين وإعادة توجيههم لهجمات سرقة الماكات والاشتراكات وغيرها.

والكارثة الكبرى هو توصيل المستخدم دون إدراك منه لجهاز اكسس بوينت جلبه لمنزلة لتقوية الاشارة، وليس على علم بأنه سيسبب مشاكل في الشبكة. والسيناريو الأسوأ هو جهاز تم برمجتة بشكل متعمد من قبل حاقد لإعادة توجيه حركة المرور أو احداث قفلات بشبكتك لتشوية سمعتها.

عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

في كلتا الحالتين ، من المهم مراقبة شبكاتنا لخوادم DHCP الغريبة . في RouterOS ، توجد أداة مفيدة في قائمة IP DHCP-Server لهذا الغرض فقط.

سنقوم أولاً بإعداد برنامج نصي لتسجيل الدخول. ثم سنقوم بتكوين تنبيهات خادم DHCP. وأخيرًا ، سنضيف عناوين MAC الموثوقة لخادم DHCP حتى لا تكون هناك إيجابيات خاطئة في سجلاتنا.

  1. Logging Script
  2. DHCP Alerts
  3. Trusted DHCP Servers
  4. Finding Rogue Devices

Logging Script

  1. قم بإنشاء البرنامج النصي لتسجيل الدخول:
    /system script add name=rogue-dhcp source=":log warning message=\"Rogue DHCP server detected!\""ملاحظة: إن الخطوط المائلة العكسية (“\”) مطلوبة .
  2. شغّل النص البرمجي وتحقق من ظهور إدخال السجل: 

    </system script run rogue-dhcp
    /log print
    /li>

    سيتم عرض إدخال السجل هذا بالإضافة إلى سجل النظام الافتراضي الذي يحتوي على عناوين MAC و IP الخادعة للملقم.

DHCP Alerts

  1. تكوين تنبيهات خادم DHCP على واجهة ether2:

[cc]/ip dhcp-server alert add interface=ether2 on-alert=rogue-dhcp disabled=no

Trusted DHCP Servers

خوادم DHCP الموثوقة:

  1. احصل على عناوين MAC لجميع خوادم DHCP الموثوقة على نطاق البث الخاص بالواجهة
  2. إضافة عناوين MAC الموثوقة إلى مثيل تنبيه خادم DHCP:

    /ip dhcp-server alert set ether2 valid-server=00:11:22:aa:bb:cc

Finding Rogue Devices

بمجرد التعرف على خادم DHCP مخادع ، من المهم تحديد موقع الجهاز وعزله. مع عنوان MAC للخادم ، من السهل تحديد المنفذ الفعلي الذي تم توصيله به. استخدم الأمر التالي لتحديد موقع الجهاز في جدول RouterOS ARP:

/ip arp print

على السويتشات أو الأجهزة مع switch chip من السهل أيضا:

/interface ethernet switch host print

يمكن إيقاف الانترفيس التي يتصل بها ملقم DHCP المريب عن بعد بينما يقوم شخص آخر بتسليم الكبل للعثور على الجهاز.

أنتهى … عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

عمل تنبيهات عند وجود جهاز غريب على الشبكة لمنع قفلات DHCP ومتابعة خطورة الموقف

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم عمل تنبيهات عند وجود جهاز غريب على الشبكة والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

لا يمكنك الاتصال بالإنترنت؟ جرب هذه النصائح والاقتراحات قد تساعدك على اعادة الاتصال بنجاح

لا يمكنك الاتصال بالإنترنت؟ جرب هذه النصائح والاقتراحات قد تساعدك على اعادة الاتصال بنجاح

لا يمكنك الاتصال بالإنترنت؟ جرب هذه النصائح والاقتراحات قد تساعدك على اعادة الاتصال بنجاح عندما …



Mohon Aktifkan Javascript!Enable JavaScript