البداية / مايكروتك / الوينبوكس / فصل الخدمة اوتماتيك عن المشتركين في المايكروتك واظهار صفحة انتهاء الاشتراك

فصل الخدمة اوتماتيك عن المشتركين في المايكروتك واظهار صفحة انتهاء الاشتراك

فصل الخدمة اوتماتيك عن المشتركين في المايكروتك :

فصل الخدمه عن المشتركين بطريقه سهلة عند نهايه الاشتراك اى بعد مرور 30 يوم من بدايه اشتراك العميل بدون اى تدخل منك

فقط كل المطلوب هو تطبيق الشرح بالاسفل حيث يقوم السكربت بتحديد اليوم الذى دخل فيه العميل على الانترنت لاول مره ثم يقوم باضافه الى الكومنت فوق اليوزر

حيث يقوم هذا السكربت الثانى بقراءه الكومنت لتحديد اليوم الذى سيقوم بفصل الخدمه عن هذا العميل فيه بطريقه اوتوماتيكيه وبدون اى مشاكل على السيرفر.

ولتفعيل هذي الخاصية اتبع الخطوات التالية :

فصل الخدمة اوتماتيك عن المشتركين في المايكروتك
فصل الخدمة اوتماتيك عن المشتركين في المايكروتك

ثم اختار البروفايل الموجود عليه العميل او يمكتك تغيير كل البروفيلات كالتالى .

فصل الخدمة اوتماتيك عن المشتركين في المايكروتك

قم بأضافه السكربت التالى فى البروفايلات الموجود عليها العملاء والمراد تطبيق هذا الشرح عليهم ( يفضل عملها على مشتركين الشهري ) واليكم السكريبت التالي :-

{
:local date [ /system clock get date ] :if ( [ /ip hotspot user get $user comment ] = "" ) do={
[ /ip hotspot user set $user comment=$date ] }
}

الخطوه 2 :- تحديد ميعاد نهايه الاشتراك لكل يوزر .

بمجرد تسجيل الدخول للعميل على النت لاول مره سيقوم السيرفر بحفظ تاريخ الاشتراك لهذا العميل ووضعه فى كومنت له .

الخطوه 3 :- اضافه سكريبت فصل الخدمه فى قائمه الجدوله …

قم باضافه الاسكربت التالى الى قائمه الجدوله كما بالصوره التاليه مع مراعاه تحديد وقت التحديث يوميا فى الساعه 12 منتصف الليل كما بالصوره التاليه …

تفعيل ظهور صفحة انتهاء الاشتراك للمايكروتك

وهذا السكربت :-

{
:local offset 7
:global today
{
:local date [ /system clock get date ] :local montharray ( "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec" )
:local monthdays ( 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 )
:local days [ :pick $date 4 6 ] :local monthtxt [ :pick $date 0 3 ] :local year [ :pick $date 7 11 ] :local months ([ :find $montharray $monthtxt] )
:for nodays from=0 to=$months do={
:set days ( $days + [ :pick $monthdays $nodays ] )
}
:set days ($days + $year * 365)
:set today $days
}
:foreach i in [ /ip hotspot user find where disabled=no ] do={
:if ([ :find [ /ip hotspot user get $i comment ] ] = 0 ) do={
:local date [ /ip hotspot user get $i comment ] :local montharray ( "jan","feb","mar","apr","may","jun","jul","aug","sep","oct","nov","dec" )
:local monthdays ( 31, 28, 31, 30, 31, 30, 31, 31, 30, 31, 30, 31 )
:local days [ :pick $date 4 6 ] :local monthtxt [ :pick $date 0 3 ] :local year [ :pick $date 7 11 ] :local months ( [ :find $montharray $monthtxt ] )
:for nodays from=0 to=$months do={
:set days ( $days + [ :pick $monthdays $nodays ] )
}
:set days ($days + $year * 365)
:if ( ($days + $offset) < $today ) do={
:local name [/ip hotspot user get $i name] :log info "HOTSPOT EXPIRE SCRIPT: Disabling Hotspot user $name first logged in $date"
[ /ip hotspot user disable $i ] [ /ip hotspot active remove [find where user=$user] ] }
}
}
}

لتحميل السكربت جاهز اضغط هنا

بعد ذلك قم بالضغط ok حيث سيقوم السكربت الاول بقرائه الكومنتات الموجوده على اليوزرات المراد فصل الخدمه عنها اليا وارسالها الى السكربت الثانى والذى يقوم بفصل الخدمه عند اليوم المحدد للمشترك بطريه اليه وسهلة وجميلة تفيذ في تنبية العميل لتجديد اشتراكة.

فصل الخدمة اوتماتيك عن المشتركين في المايكروتك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager تمكين المستخدمين المحددين تسجيل الدخول …



Mohon Aktifkan Javascript!Enable JavaScript