البداية / مايكروتك / رولات وسكربتات / استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

إذا كان لديك سيرفر ميكروتك مع اتصال DSL مع ip ديناميكي ، والذي يتغير عند كل إعادة تشغيل / إعادة تعيين ، وتريد الوصول إلى mikrotik من الإنترنت ، فيمكنك استخدام خدمة changeip.com (DynamicDNS) ، باستخدام هذه الخدمة ، ليس لديك حاجة للاستعلام عن DSL IP في كل مرة ، كل ما عليك أن تتذكر اسم النطاق الذي قمت بتسجيله على الموقع ، وسيتم التعامل مع بقية الأشياء من قبل DDNS النصي الذي تم تكوينه على Mikrotik.

اليكم السينيارو التالي الذي سيتم :-

…    INTERNET            >>    DSL MODEM          >>> MIKROTIK
User with WINBox                  (with dynamic ip)

DSL MODE IP              =   192.168.30.1
MIKROTIK WAN IP =  192.168.30.5

تهيئة DSL MODEM لتمكين بورت اعادة التوجية :-

أفتح صفحة المودم DSL أولاً لتمكين إعادة التوجيه للمنفذ (من مودم DSL إلى مربع Mikrotik)
الآن أضف قاعدة إعادة توجيه المنفذ

يستخدم WINBOX منفذ TCP 8291
كما هو موضح في الصورة أدناه. . .

استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة
استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

اضغط الان على SAVE / APPLY

إنشاء حساب جديد على CHANGEIP.COM

الآن افتح http://www.changeip.com في متصفحك وسجل حساب جديد.
كما هو موضح في الصورة أدناه :-

DynamicDNS

الدخول عن بعد للميكروتك

الآن سوف سترسل لك رسالة تأكيد بالبريد الإلكتروني ، افتح صندوق بريدك ، وانقر على الرابط الذي أرسل لك لتنشيط حسابك.

أضف اسم النطاق إلى حسابك

سجل الدخول لرؤية حسابك ، افتراضيا لا يضاف أي اسم ، فقط اضغط على مدير DNS لإضافة اسمك المطلوب
كما هو موضح في الصورة أدناه :

الدخول الى الشبكة عن بعد

الآن عليك أن تضيف اسمك المطلوب ونطاقه. يمكنك تحديد المجالات المختلفة من القائمة المنسدلة.

DynamicDNS

بعد إضافة اسم نطاقك ، يمكنك رؤية اسم نطاقك في الصفحة الرئيسية ،

الدخول عن بعد

الآن حان الوقت لتكوين البرنامج script DynamicDNS على Mikrotik.

تكوين DDNS SCRIPT و SCHEDULER على MIKROTIK

تسجيل الدخول إلى ميكروتيك عبر WINBOX ،
انتقل إلى Scripts / و new script..

ألصق التالي في script

SCRIPTNAME: ddns-script-behind-dsl-modem
اختبار الـ Script Code مع الإصدار 6.xx MIKROTIK

# Set your specific ChangeIP.com preferences here.
:global ddnsuser "CHANGEIP USERNAME"
:global ddnspass "PASSWORD"
:global ddnshost "YOUR-FREE-DDNS SITE NAME"
# Change ddnsport to 8245 to bypass proxy.
:local ddnsport 80
# Do not edit anything below this line. You have been warned.
# Abusive updates to the system will cause firewall blocks.
# Please be considerate and
# do not let this script run more than once per 3-5 minutes.
:log info "DDNS: Starting."
# Initialize checkpoint
:global ddnscheckpoint
:if ([:typeof $ddnscheckpoint] = "time") do={
:log info ("DDNS: Last check was " . ([/system clock get time] - $ddnscheckpoint))
} else={
:log info "DDNS: Cannot determine checkpoint, set now."
:global ddnscheckpoint ( [/system clock get time] - 1d )
}
# Get the current IP
:if ([/system clock get time] - $ddnscheckpoint > [:totime 180s] || [/system clock get time] - $ddnscheckpoint < [:totime 0s]) do={
:log info "DDNS: Performing remote IP detection."
/tool fetch address="ip.changeip.com" host="ip.changeip.com" src-path=("/?" . [/int eth get 0 mac-address ]) dst-path="ip.changeip.com.txt" mode=http port=$ddnsport
:global ddnscheckpoint [/system clock get time] } else={
:log info "DDNS: Please be considerate and wait a few seconds longer."
:break
}
# Parse the IP address received from fetch script.
:global ddnslastip
:local html [/file get "ip.changeip.com.txt" contents] :local ddnsip [:pick $html ([:find $html ""] ] # Is it a valid IP and is it different than the last one?
:if ([:typeof [:toip $ddnsip]] = "ip" AND $ddnsip != $ddnslastip ) do={
:log info "DDNS: Sending UPDATE with $ddnsip"
:log info [/tool dns-update name=$ddnshost address=$ddnsip key-name=$ddnsuser key=$ddnspass ] :global ddnslastip $ddnsip
} else={
:log info "DDNS: No update required."
}
}

Script for Mikrotik ver 6.x  [CODE FOR PPP DIALER WHERE INTERNET IS DIRECTLY CONNECTED ON MIKROTIK

:local ddnsuser "USERNAME"
:local ddnspass "PASSWORD"
:local ddnshost "CHANGEIP_YOUR_WEB_NAME"
:local ddnsinterface "WAN_INTERFACE"
:global ddnslastip
:global ddnsip [ /ip address get [find interface=$ddnsinterface disabled=no] address ] :if ([ :typeof $ddnslastip ] = nil ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = nil ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.") } else={
:if ($ddnsip != $ddnslastip) do={
:log info "DDNS: Sending UPDATE!"
:log info [ /tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] :global ddnslastip $ddnsip } else={
:log info "DDNS: No change" }
}

paste-script-in-terminal
paste-script-in-terminal

للتحقق من لصق النص البرمجي والعمل بشكل صحيح ،
انتقل إلى SYSTEMS> SCRIPTS وانقر نقرًا مزدوجًا على DDNS لعرض محتوياته ، فقط تأكد من أن كل شيء في مكانه.

الدخول عن بعد للميكروتك

حسنًا ، نظرًا لأن script في  موضعه ، حان وقت تنفيذ script حتى يمكنه تحديث بروتوكول WAN IP الحالي إلى حساب DynamicDNS.

script-executed-result-ok-dns-updated

كما ترون أن الـ script قام بتحديث السجل إلى حساب dynamicDNS .

إضافة جدولة scheduler (بحيث يمكن تحديث السجل بعد كل 5 دقائق)

أضف هذا أيضًا في المجدول ( scheduler  ) بحيث يمكن تشغيله بعد كل 5 دقائق ، يمكنك ضبطه وفقًا لمتطلباتك.

/system scheduler
add disabled=no interval=5m name="Run DDNS every 5 minutes" on-event=update-ddns policy=\
ftp,reboot,read,write,policy,test,winbox,password,sniff,sensitive,api start-date=mar/30/2012 start-time=14:24:00

التحقق من IP تسجل على CHANGEIP.COM

ارجع إلى changeip.com وشاهد سجل اسم النطاق الخاص بك بالنقر فوق

عرض آخر التحديثات DDNS

الآن سوف يظهر لك السجل المحدث.

كل شيء جاهز الآن وفي مكانه.

الان لنجري اختبار بسيط للتاكد من امكانية الاتصال بالميكروتك عبر الانترنت:-

حان الوقت الان  😛 . من أي جهاز كمبيوتر آخر يعمل عن بعد مع اتصال منفصل بالإنترنت ، حاول استخدام الأمر ping لاسم النطاق الخاص بك وحاول توصيله عبر winbox أو حاول فتحه في متصفحك ،

ملاحظة : في الصورة أدناه ، استخدمت اسم نطاق آخر ، في اللحظة التي كنت أملك فيها هذا النطاق ، لذا تجاهل الاسم ، فقط افهم القصد بوضع نطاقك الذي سجلت به

ping-winbox-via-dns-name

mikrotik-web-via-dns-name
mikrotik-web-via-dns-name

تلميح: السكريبت لمودم DSL في حالة الوضع BRIDGE …

إذا كان لديك مودم DSL تم تكوينه في وضع BRIDGE ، وكنت تقوم بالاتصال من خلال Mikrotik PPPoE Client ، استخدم Script التالي.

ملحوظة:

تأكد من تغيير هوية المستخدم + كلمة المرور + اسم المضيف لمطابقة الاسم الذي أدخلته في وقت التسجيل.
الأهم من ذلك لايجب أن ننسى تغيير اسم الواجهة (على سبيل المثال pppoe-out1 أو بالمثل )

http://wiki.mikrotik.com/wiki/Dynamic_DNS_Update_Script_for_ChangeIP.com

ddns-script-modem-in-pppoe-mode- code.

:global ddnsuser "user-aacable"
:global ddnspass "passwd"
:global ddnshost "full hostname"
:global ddnsinterface "pppoe-out1"
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
# END OF USER DEFINED CONFIGURATION
# ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
:global ddnssystem ("mt-" . [/system package get [/system package find name=system] version] )
:global ddnsip [ /ip address get [/ip address find interface=$ddnsinterface] address ] :global ddnslastip
:if ([:len [/interface find name=$ddnsinterface]] = 0 ) do={ :log info "DDNS: No interface named $ddnsinterface, please check configuration." }
:if ([ :typeof $ddnslastip ] = "nothing" ) do={ :global ddnslastip 0.0.0.0/0 }
:if ([ :typeof $ddnsip ] = "nothing" ) do={
:log info ("DDNS: No ip address present on " . $ddnsinterface . ", please check.")
} else={
:if ($ddnsip != $ddnslastip) do={
:log info "DDNS: Sending UPDATE!"
:log info [ :put [/tool dns-update name=$ddnshost address=[:pick $ddnsip 0 [:find $ddnsip "/"] ] key-name=$ddnsuser key=$ddnspass ] ] :global ddnslastip $ddnsip
} else={
:log info "DDNS: No changes necessary."
}
}
# END OF THE SCRIPT

استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة

والذي نتمنى ان ينال رضاكم واعجابكم

والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع استخدام DynamicDNS للدخول الى سيرفر الميكروتك من خارج الشبكة لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة إذا كان لديك …



Mohon Aktifkan Javascript!Enable JavaScript