البداية / مايكروتك / رولات وسكربتات / الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

هذا السكربت مخصص لأولئك الذين يريدون IP Range معين عند الاتصال مع PPPoE إلى ISP الخاص بك.

فبدلاً من تعطيل pppoe client وتمكينه باستمرار ، كل ما عليك فعله هو تشغيل هذا السكربت.


الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

قد ترغب في نطاق IP Range معين لأي عدد من الأسباب. في بعض الأحيان ، نستخدم هذا للتحقق من المسارات التي يستخدمها مزود خدمة الإنترنت. حيث تختلف المسارات التي يستخدمها في نطاقات IP Range معينة. لهذا نأمل أن يجدي هذا نفعا.

وهذا موضوع بمنتدى ميكروتك للمناقشة

هناك 3 متغيرات للتعيين : targetip و pppoedelay. if: name of pppoe-client interface targetip: على سبيل المثال: 177.0.0.0/8 أو 65.50.0.0/16 pppoedelay: يكفي التأخير بحيث يعطي مزود خدمة الإنترنت IP جديدًا بدلاً من سابقته. حيث يمكنك اللعب بهذا .

:global if "pppoe-out1"
:global targetip 210.0.0.0/8
:global currentip [/ip address get [/ip address find interface=$if ] address]
:global ip $currentip
:global pppoedelay 10s

:put "Current IP: $currentip\r\nTarget: $targetip\r\n"

:while (!($currentip in $targetip)) do={
     put "$currentip is not in $targetip. Getting new IP. $pppoedelay delay"
     /interface disable $if
     :delay $pppoedelay
     /interface enable $if
     :do {delay 1s; put "waiting for pppoe-server"} while=( [/interface get unifi running]=false)
     :set currentip [/ip address get [/ip address find interface=$if ] address]
     :set currentip ([[:parse ":return $currentip"]])
     :set ip $currentip
     }
:put "Target obtained: $currentip"

أفضل لتشغيل من CLI حتى تتمكن من رؤية الإخراج. مثال:

[[email protected]] /system script> run pppoe-ip-cidr 
Current IP: 175.144.175.247/32
Target: 210.0.0.0/8

175.144.175.247/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
175.144.175.247/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
175.136.3.130/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
175.136.3.130/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
118.101.248.194/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
175.144.175.247/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
118.100.151.60/32 is not in 210.0.0.0/8. Getting new IP. 00:00:10 delay
waiting for pppoe-server
waiting for pppoe-server
Target obtained: 210.187.203.102/32
[[email protected]] /system script>

أنتهى … الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

نتمنى ان يكون الموضوع واضح ومبسط

واي استفسارات يمكنكم وضعها بالمنتديات للرد عليكم او وضعها على التعليقات اسفل الموضوع  … شكرا لمتابعتكم

الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود واحترام والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

adblock script mikrotik

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة لقد كنت أستخدم سكربت لمنع …



Mohon Aktifkan Javascript!Enable JavaScript