البداية / مايكروتك / دمج خطوط / دمج الخطوط وموازنة الاحمال في سيرفر المايكروتك بطريقة PPC – حضرموت التقنية

دمج الخطوط وموازنة الاحمال في سيرفر المايكروتك بطريقة PPC – حضرموت التقنية

دمج الخطوط وموازنة الاحمال في سيرفر المايكروتك بطريقة PPC – حضرموت التقنية

اليوم سنوضح طريقة جديدة في دمج الخطوط على سيرفر المايكروتك اي موازنة الاحمال بطريقة PPC

يوضح هذا المقال كيف يمكنك تكوينأو انشاء موازنة متساوية بين خطوط الشبكة  wan متعددة باستخدام أجهزة Mikrotik Routerboard (أو إصدار RouterOS x86).

في هذا المثال ، استخدمت نموذج Mikrotik Routerboard CCR 1036. لا تنس إعادة تسمية أسماء الواجهة وفقًا لذلك إذا كنت ستقوم بعملية النسخ واللصق للكود المستخدم ادناة .

دمج الخطوط وموازنة الاحمال
دمج الخطوط وموازنة الاحمال

الان قم بتوصيل الراوترات ADSL  بمنفذي ال WAN والمنفذ الثالث سيكون للخروج LAN للمشتركين والخطوط سرعات متساوية بأجمالي 10 ميقا مثلا :

ال IP للراوترات ADSL ستكون على النحو التالي :

DSL MODEM 1 = 192.168.1.1
DSL MODEM 2 = 192.168.2.1

في هذا المثال ، سنستخدم أسلوب PCC لتحقيق توازن السحب بين الخطوط . حيث هناك عدد قليل من الخيارات التي تستخدم هذه الطريقة وقد يمنحك كل خيار نتائج مختلفة .

المثال رقم 1: src-address
استخدام src-address كمصنف ، وبهذه الطريقة سوف نتخلص من المشاكل مثل https / break link، streaming issues etc (dueot ip changing on each request).

تتطلب موازنة التحميل للخطوط باستخدام PCC technique (src-address) أنه يجب على المستخدمين الوصول إلى مجال ال PCC مباشرة (إما خادم dhcp / ppp ، إلخ).

في هذه الطريقة ، سيتم تمييز المستخدم برابط WAN محدد بمجرد توصيله بـ mikrotik .

المثال رقم 2: both-addresses-and-ports
إذا لم تكن راضيًا بطريقة ما عن (src-address) (أو متطلباتك هي تحقيق أقصى سرعة تنزيل باستخدام جميع روابط WAN في وقت واحد) .

قم بتجربة كل العناوين والمنافذ كمصنف (كما هو مستخدم في هذا الدليل كذلك). في حين أن هذا سيجعل الأمور بشكل عشوائي أكثر من الناحية النظرية ، ويعطيك أكثر تخصيص كطريقة عادلة في عرض النطاق الترددي (كما سيتم توزيع أي طلب بين جميع الروابط WAN) .

ولكن هناك أيضا فرصة جيدة أنها ستكسر أشياء معينة مثل مواقع الويب المصرفية وبعض المنتديات. ويرجع ذلك إلى أن طلبات HTTP في كثير من الأحيان ستولد العديد من الاتصالات ، لذا هناك احتمال أن تخرج بعض الطلبات مسارًا مختلفًا عن المسار الأول ، وهذا سيؤدي إلى قطع مواقع الويب الآمنة.

ولهذا السبب ، عادةً يفضل التعامل مع نهج موازنة تحميل PCC عنوان src-address .

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

كله تمام ! الآن اختبر الارتباط من خلال تحميل المستخدم ، وكلما زاد عدد المستخدمين الذين قمت بوضعهم عليه في الاكتف ، كلما كانت نتيجة تحميل الرصيد أفضل عبر الراوترات 🙂

دمج الخطوط وموازنة الاحمال

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم دمج الخطوط وموازنة الاحمال

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة… حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

سيرفر دمج مايكروتك

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية Server integration of …



Mohon Aktifkan Javascript!Enable JavaScript