البداية / مايكروتك / دمج خطوط / Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

تناولنا عدة طرق للدمج في سيرفر الميكروتك ولازلنا نوضح افضل الطرق كل ما تمكن لنا ذلك .

التالي هو سكربت كامل ل Mikrotik لدمج / تحميل التوازن بين خطين DSL. في هذا المثال استخدمت جهاز التوجيه MikrotikT 5 منافذ.

Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

تم توصيل عدد 2 منافذ براوترين ADSL

وتم توصيل المنفذ الثالث بـ User LAN.

كلا DSL بنفس السرعة ، أي مثلا  10 ميغابايت لكل منهما.

DSL MODEM IP’S
DSL MODEM 1 = 192.168.1.1
DSL MODEM 2 = 192.168.2.1

لا تنس أيضًا إعادة تسمية أسماء الواجهة interface  وفقًا لذلك.

في تجربتي ، إذا كان طلب المستخدمين هو الاتصال عبر Mikrotik بعد تكوينه مباشرة مع PCC ، فسوف تحصل على موازنة جيدة.

استخدم src-address كمصنف ، وبهذه الطريقة سوف تتخلص من المشاكل مثل https / link broken ، streaming issues إلخ.

موازنة التحميل للخطوط باستخدام تقنية PCC هذه (src-address) ستكون طريقة فعالة ومتوازنة عند تشغيل المزيد أو إضافة المزيد من الاتصالات (من العملاء ) اذا حصل ذلك.

كما أوصي باستخدام خادم بروكسي SQUID جنبا إلى جنب مع mikrotik ، إما موازية أو أمامية أو خلفية ، لوقت استجابة أفضل ، وسوف تزيد أيضا تجربة تصفح جيدة للمستخدمين.

إذا لم تكن راضيًا بطريقة ما عن طريقة عنوان src-address ، فابدأ مع PCC-Classifier ، ثم جرّب كل من العناوين والمنافذ كمصنف.

في حين أن هذا سيعطي الأمور عشوائياً أكثر من الناحية النظرية ، إلا أنه من الناحية النظرية سيوفر لك التوزيع العادل للنطاق الترددي .

ولكن هناك أيضاً فرصة جيدة لكسر أشياء معينة مثل مواقع الويب المصرفية وبعض المنتديات ذات التشفير HTTPS.

ويرجع ذلك إلى أن طلبات HTTP في كثير من الأحيان ستولد العديد من الاتصالات ، لذا هناك احتمال أن تخرج بعض الطلبات مسارًا مختلفًا عن المسار الأول ، وهذا سيؤدي إلى قطع مواقع الويب الآمنة.

لهذا السبب أنا عادة ما احبذ العمل مع عنوان src لموازنة تحميل PCC.

لنسخ الاكواد ضع المؤشر على الكود وستظهر علامة + اضغط عليها وانسخ

/ip address
add address=192.168.0.1/24 network=192.168.0.0 broadcast=192.168.0.255 interface=Local
add address=192.168.1.2/24 network=192.168.1.0 broadcast=192.168.1.255 interface=WAN1
add address=192.168.2.2/24 network=192.168.2.0 broadcast=192.168.2.255 interface=WAN2
/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=8.8.8.8
/ip firewall mangle
add chain=input in-interface=WAN1 action=mark-connection new-connection-mark=WAN1_conn
add chain=input in-interface=WAN2 action=mark-connection new-connection-mark=WAN2_conn
add chain=output connection-mark=WAN1_conn action=mark-routing new-routing-mark=to_WAN1
add chain=output connection-mark=WAN2_conn action=mark-routing new-routing-mark=to_WAN2
add chain=prerouting dst-address=192.168.1.0/24 action=accept in-interface=Local
add chain=prerouting dst-address=192.168.2.0/24 action=accept in-interface=Local
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting connection-mark=WAN1_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN1
add chain=prerouting connection-mark=WAN2_conn in-interface=Local action=mark-routing new-routing-mark=to_WAN2
/ip route
add dst-address=0.0.0.0/0 gateway=192.168.1.1 routing-mark=to_WAN1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 routing-mark=to_WAN2 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.1.1 distance=1 check-gateway=ping
add dst-address=0.0.0.0/0 gateway=192.168.2.1 distance=2 check-gateway=ping
/ip firewall nat
add chain=srcnat out-interface=WAN1 action=masquerade
add chain=srcnat out-interface=WAN2 action=masquerade

كله تمام !

الآن اختبر الارتباط من خلال تحميل المستخدم ، وكلما زاد عدد المستخدمين الذين قامو بالتحميل ، كلما كانت نتيجة تحميل الرصيد أفضل .

PCC WITH UN-EQUAL WAN LINKS

إذا كانت لديك روابط Un-Equal WAN ، على سبيل المثال WAN ، 1 من 4MB و WAN ، و 2 من 8 ميجا بايت ، وتريد فرض MT لاستخدام WAN42link أكثر من غيرها بسبب قدرتها ، عندها عليك إضافة المزيد من PCC rules .

add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/0 action=mark-connection new-connection-mark=WAN1_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/1 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes
add chain=prerouting dst-address-type=!local in-interface=Local per-connection-classifier=both-addresses-and-ports:2/2 action=mark-connection new-connection-mark=WAN2_conn passthrough=yes

PCC مع HOTSPOT (Reference) :

/ip firewall nat add action=accept chain=pre-hotspot disabled=no dst-address-type=!local hotspot=auth

أنتهى … Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله

اذا اعجبك الموضوع Mikrotik DUAL WAN موازنة الأحمال ( الدمج ) باستخدام طريقة PCC في المايكروتك لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات بالمنتديات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

دمج خطين متساويين بطريقه PCC بريدج على كرتين لان

دمج خطين متساويين بطريقه PCC بريدج : كنا قد تحدثنا في موضوع سابق عن طريق …



Mohon Aktifkan Javascript!Enable JavaScript