البداية / مايكروتك / رولات وسكربتات / سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

هذا هو سكربت بسيط مفيد من نوع RouterOS والذي يرسل إليك تقريرًا رائعًا عندما يعيد الميكروتك التشغيل.

يحتوي التقرير المرسل بالبريد الإلكتروني على أحداث سجل حرجة حديثة قد توجهك إلى سبب إعادة التشغيل.

أي “تم إعادة تشغيل جهاز الميكروتك بدون إيقاف التشغيل الصحيح” أو “تم اكتشاف حالة خارج الذاكرة” وهكذا.

اليكم السكربت :

:delay 1
 
:local reportBody ""
 
:local deviceName [/system identity get name]
:local deviceDate [/system clock get date]
:local deviceTime [/system clock get time]
:local hwModel [/system routerboard get model]
:local rosVersion [/system package get system version]
:local currentFirmware [/system routerboard get current-firmware]
:local upgradeFirmware [/system routerboard get upgrade-firmware]
 
 
:set reportBody ($reportBody . "Router Reboot Report for $deviceName\n")
:set reportBody ($reportBody . "Report generated on $deviceDate at $deviceTime\n\n")
 
:set reportBody ($reportBody . "Hardware Model: $hwModel\n")
:set reportBody ($reportBody . "RouterOS Version: $rosVersion\n")
:set reportBody ($reportBody . "Current Firmware: $currentFirmware\n")
:set reportBody ($reportBody . "Upgrade Firmware: $upgradeFirmware")
if ( $currentFirmware < $upgradeFirmware) do={
:set reportBody ($reportBody . "NOTE: You should upgrade the RouterBOARD firmware!\n")
}
 
:set reportBody ($reportBody . "\n\n=== Critical Log Events ===\n" )
 
:local x
:local ts
:local msg
foreach i in=([/log find where topics~"critical"]) do={
:set $ts [/log get $i time]
:set $msg [/log get $i message]
:set $reportBody ($reportBody  . $ts . " " . $msg . "\n" )
}
 
:set reportBody ($reportBody . "\n=== end of report ===\n")
 
/tool e-mail send subject="[$deviceName] Router Reboot Report" to="[email protected]" body=$reportBody

تركيب السكربت :

أفتح الـ Winbox ، ثم قم بنسخ ولصق السكربت أعلاه في System | Scripts على جهاز MikroTik Router الخاص بك بعمل اضافة بالضغط على الرمز ( + ). يجب تسمية السكربت router-restart-report.

كما موضح بالصورة ادناة :

سكربت التنبية بإعادة التشغيل للميكروتك - تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

إعداد بالسكربت للتشغيل عند بدء اعادة التشغيل للميكروتك :

بعد الانتهاء من إضافة السكربت، انتقل إلى System | Scheduler وقم بإنشاء جدولة جديدة للتشغيل عند بدء التشغيل.

لاحظ الصورة ادناة :

تشغيل سكربت ارسال تنبية باعادة تشغيل السيرفر

نريد تشغيل السكربت في كل مرة يقوم فيها الراوتر بإعادة التشغيل ، لذلك اختر من القائمة المنسدلة Start Time “startup”

في القسم “On Event” من الجدول ، الصق الأوامر التالية :

:delay 30
/system script run router-reboot-report

يجب أن يتطابق اسم السكربت تمامًا مع اسم النص البرمجي الذي أضفته. يمنح التأخير 30 ثانية جهاز التوجيه فرصة للحصول على الاتصال بعد إعادة التشغيل. إذا فشل إرسال البريد الإلكتروني ، فقد تحتاج إلى زيادة التأخير.

تكوين التسجيل :

لكي يعمل هذا السكربت بشكل صحيح ، يجب عليك تكوين تسجيل مستمر على جهاز MikoTik Router الخاص بك. إذا لم تكن سجلاتك ثابتة عبر عمليات إعادة التشغيل ، فقد تفوّت بعض أحداث السجل المهمة التي تروي قصة سبب إعادة تشغيلها في المقام الأول. لتكوين التسجيل المستمر ، يرجى الاطلاع على صفحة التسجيل على موقع mikrotik wiki.


مثال لتقرير البريد الإلكتروني

هذا ما يبدو عليه التقرير ، ستتلقى هذه الرسالة الإلكترونية في كل مرة يقوم فيها الراوتر بإعادة التشغيل. كما يمكنك أن ترى في المثال إعادة تشغيل جهاز الراوتر الخاص بي مؤخرًا مع وجود حالة خارج الذاكرة. يوفر التقرير أيضًا الإصدار الحالي من إصدار RouterOS بالإضافة إلى معلومات إصدار البرنامج الثابت.

example-email-report

يمكن أن يساعد هذا السكربت في استكشاف أخطاء عمليات إعادة التشغيل العشوائية والأعطال غير المتوقعة.

آمل أن تجد هذا الموضوع للسكربت مفيد .

أنتهى … سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع سكربت التنبية بإعادة التشغيل للميكروتك – تلقى اشعارا فوري باوقات اعادة تشغيل السيرفر وسبب ذلك لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة إذا كان لديك …



Mohon Aktifkan Javascript!Enable JavaScript