البداية / مايكروتك / اليوزر مانجر / شرح خادم Mikrotik PPPoE مع نظام إدارة الفواتير المدفوعة مسبقا User Manager

شرح خادم Mikrotik PPPoE مع نظام إدارة الفواتير المدفوعة مسبقا User Manager

شرح خادم Mikrotik PPPoE مع نظام إدارة الفواتير المدفوعة مسبقا User Manager

سيوضح هذا الموضوع كيفية إنشاء ملقم PPPoE في MIKROTIK RouterOS (سنستخدم نسخة v 5.6 في هذا المثال).

وستوضح هذه المقالة أيضًا كيف يمكنك إنشاء الفوترة التلقائية المدفوعة مسبقًا للمستخدمين الذين يستخدمون User Manager من سيرفر الـ  Mikrotik.

يمكن استخدام خادم RADIUS الأساسي a.k.a USERMAN لأي خدمة ppp مثل VPN / PPPoE / HOTSPOT.

ملاحظة :-
يجب أن أذكر أن الـ USERMAN ليس موثوقًا به ، فلا يمكنك الاعتماد عليه كخادم إنتاج لشبكة كبيرة ، لذلك لا نتوقع الكثير منه ، وإذا كنت تريد ميزات حقيقية تتعلق بـ ISP ، فمن الأفضل استخدام خادم Radius 3rd مثل DMASOFTLAB  وهو غني بالمميزات ومصمم لأداء أفضل 🙂

كما سيوضح لك كيفية إنشاء حساب بحد 30 يومًا بحد أقصى للسرعة يبلغ 256 كيلوبت في الثانية.

سوف نقسم هذه المقالة في قسمين رئيسيين :-

1) خادم PPPoE (الإعدادات الأساسية)
2) إعداد فوترة مدير المستخدمين
User Manger

في هذا المثال ، يحتوي الـ  Mikrotik على بطاقتي lan.
1) ether1 = ip 10.0.0.1 / LAN واجهة استضافة PPPoE Server
2) ether2 = ip 192.168.0.1 / WAN واجهة متصلة بـ DSL / Fiber إلخ.

(قم بتكوين واجهاتك وفقًا لشبكتك ، في سلسلة الصور ip 192.168.2.1 ، لا ترتبك معها. يمكنك ضبطها وفقًا لذلك)

أعدادPPPoE SERVER :

أولا سنقوم بإضافة PPPoE Server باستخدام واجهة سطر الأوامر (CLI) نيوترمنال :

/interface pppoe-server server
add authentication=pap default-profile=default disabled=no interface=ether1 keepalive-timeout=10 max-mru=1480 max-mtu=1

الآن سنقوم بإضافة IP Pool للمستخدمين pppoe :

/ip pool add name=pppoe-users-pool ranges=172.16.0.1-172.16.0.254

الآن سنقوم بإضافة ملف تعريف جديد لمستخدمي pppoe :

/ppp profile add change-tcp-mss=default dns-server=10.0.0.1 local-address=10.0.0.1 name=pppoe-profile only-one=default remote-address=pppoe-users-pool use-compression=default use-encryption=default use-vj-compression=default

أضف الرول التالي للسماح بالإنترنت :

/ip firewall nat add action=masquerade chain=srcnat disabled=no src-address=172.16.0.1-172.16.0.255

(في حالة masquerading rule ، أضفت عنوان src إلى 172.16.0.x ip pool ، بحيث يعمل فقط pppoe المتصلين بالإنترنت)

إضافة خادم DNS :

/ip dns set allow-remote-requests=yes cache-max-ttl=1w cache-size=5000KiB max-udp-packet-size=512 servers=221.132.112.8

الآن أخيرا سنقوم بإضافة مستخدم محلي لاختبار حالة خادم pppoe :

/ppp secret add caller-id="" disabled=no limit-bytes-in=0 limit-bytes-out=0 name=zaib password=1234 profile=pppoe-profile routes="" service=pppoe

الآن في نهاية المستخدم ، سيتم إنشاء طلب pppoe للاتصال مع معرف = zaib وكلمة المرور = 1234

إذا سارت الأمور على ما يرام ، سوف تبدأ في تصفح الإنترنت بسلاسة .

الآن سوف ننتقل إلى نظام الفوترة mikrotik باستخدام الباكج المدمج المسمى USER MANAGER.

أعداد USER MANAGER والفواتير ( الكروت ) :

يمكننا إعداد خادم RADIUS في mikrotik باستخدام الخادم  المسمى بـ User Manager .

 UM  أو User Manager هي حزمة إدارة الفوترة على شبكة الإنترنت لاكمال طلبات المصادقة hotspot / pppoe / vpn في RouterOS.

وهو مكون يعتمد على RADIUS حتى يمكنه توفير إدارة مركزية لمفاتيح NASes فردية أو متعددة تستند إلى RouterOS.

الآن سنقوم أولاً بتكوين مدير المستخدمين ثم نقوم لاحقاً بدمجه مع خادم pppoe الخاص بنا بحيث سيتم إجراء جميع المصادقات عبر UM.

ركزو هنا معاي ان  – UM – نقصد بها هنا اليوزر مانجر

افتح متصفح الويب الخاص بك وأكتب  http://10.0.0.1/userman او بحسب عنوان الـ IP الخاص بك للدخول الى مدير المستخدمين اليوزر منجر .

سترى شاشة مصادقة دخول مدير المستخدمين ، والآن أدخل معرف المشرف وكلمة المرور وسيتم توجيهك إلى شاشة UM الرئيسية .
ملاحظة: إذا لم تنجح كلمة مرور المشرف الافتراضية ، فغيّر كلمة المرور من خلال اتباع الأمر

/tool user-manager customer set admin password=PASSWORD
**OR**
/tool user-manager customer print

شرح خادم Mikrotik PPPoE

انقر الآن على الملفات الشخصية ، على النافذة اليمنى ، انقر على علامة + (بجانب الملف الشخصي)

لأغراض الاختبار ، سنقوم بإضافة ملف تعريف واحد بسرعة 256 كيلوبت في الثانية ، والحد الأقصى لمدة 30 يومًا. يمكنك إضافة العديد من الحزم وفقًا لمتطلباتك لاحقًا ، بمجرد أن تفهم كيفية عمل ذلك )

الآن نريد إضافة 256 كيلوبايت / 30 يوم كحد أقصى ، واسمه 256 كيلوبايت.

* في نوع “الاسم للمستخدمين” ، 256 كيلوبايت
* في “الصلاحية” ، اكتب “4w2d” (لمدة صلاحية شهر واحد)
* في “بدء” ، حدد “عند أول تسجيل دخول” (سيبدأ وقت المستخدم عند تسجيل دخول المستخدم لأول مرة)
* في “السعر” ، أدخل المبلغ الذي تبيع به هذه الحزمة للمستخدمين. مثل 400
* في “المستخدمون المشتركون” ، حدد “1” (بحيث لا يمكن استخدام معرّف فردي من أجهزة كمبيوتر متعددة في آنٍ واحد)

الآن بعد الانشاء احفظ الملف الشخصي. (انظر للقطة الشاشة ادناة)

إضافة مستخدم لليوزرمانجر
شرح خادم Mikrotik PPPoE

الآن نريد إضافة حدود الباندوث إلى هذا الملف الشخصي ، انتقل إلى “القيود” وانقر على إضافة ،
سوف تظهر نافذة جديدة

* في نوع “الاسم” 256 كيلوبايت
* في “Rate Limit” in RX ‘128k’ in TX ‘256k’ ،
انقر الآن على “حفظ”. (انظر للقطة الشاشة ادناة)

اضافة حجم التحميل لليوزر

الآن نعود إلى قسم Profiles . هنا سترى 256k الخاصة بك التي تم إنشاؤها

الملف الشخصي ، clien على “Add New Limitation” وانقر على “256 كيلوبايت” وانقر على زر “إضافة ADD” . (انظر للقطة الشاشة ادناة)

يوزرمانجر
شرح خادم Mikrotik PPPoE

تم الانتهاء من إنشاء أول حزمة باستخدام حد 256 كيلوبايت و 30 يومًا. الآن سنقوم بإضافة مستخدم جديد ووضع علامة عليها باستخدام هذا الملف الشخصي الجديد 256 كيلوبايت.

انتقل إلى المستخدمين ، وانقر على إضافة / واحد (لإضافة مستخدم واحد).

* في نوع “اسم المستخدم” “zaib”
* في “كلمة المرور” اكتب “1234”
* في “قيود” التحقق من “استخدام معرفCalled ID ” Bindon لأول مرة. هذه الخيارات جيدة إذا كنت تريد ربط معرف المستخدم بعنوان MAC الأول الذي تم اكتشافه ، إذا كنت لا تريد ربطه ، فاترك هذا الخيار كما هو.
* في “Assign profile” select select 256k’s profile and click on ADD button to finish.
(انظر للقطة الشاشة ادناة)

um-add-new-user
شرح خادم Mikrotik PPPoE

الآن بعد أن انتهينا من عملنا الأساسي مع UM ، جاء الوقت لدمجه مع Mikrotik ، بحيث يتم تنفيذ مصادقة ميكروتيك PPPoE عبر UM اليوزر مانجر 😛 .
سنحتاج لتعديل بعض الإعدادات ، سواء على UM و Mikrotik كذلك.

في UM لدينا إضافة Mikrotik Router.

* في UM ، انتقل إلى أجهزة التوجيه Routers ، إضافة ADD ،جديد NEW ، قم بتسمتها Mikrotik ،
* في IP Address اكتب عنوان IP الخاص بالخادم ، 10.0.0.1
* في النوع “Shared Secret” ، اكتب “1234”
الآن انقر فوق “إضافة ADD ” لإنهاء.

(انظر الصورة المرفقة ادناة) – (في عنوان IP للصورة يظهر 192.168.2.1 ، لا تخلط بين الامور ، فقط استخدم فئة عنوان IP الخاص بك هنا)

um-radius-add
شرح خادم Mikrotik PPPoE

اكتمل قسم UM ، والآن سننتقل إلى MIKROTIK لإكمال إعداد الـ RADIUS.

افتح Mikrotik Terminal والصق الامر التالي:

/ppp aaa set accounting=yes interim-update=0s use-radius=yes
/radius add accounting-backup=no accounting-port=1813 address=10.0.0.1 authentication-port=1812 called-id="" disabled=no domain="" realm="" secret=1234 service=ppp,hotspot timeout=300ms
/radius incoming set accept=yes port=3799

تأكد من تغيير عنوان IP وفقًا للتهيئة المحلية.

وهكذا انتهينا .

الآن اتصل بـ User id’ zaib وكلمة المرور 1234 التي أنشأتها عبر UM. يجب أن تربط بشكل جيد. بعد الاتصال لأول مرة ، تنتهي صلاحية هذا المعرِّف في غضون 30 يومًا وسيكون الحد الأقصى لحزمة النطاق الترددي هو 256 كيلوبايت وتنزيل 128 كيلوبايت.

ولعرض الحالة / تغيير كلمة المرور ، إلخ ، من جانب العميل ،اكتب بالمتصفح :

http://10.0.0.1/user أو http://192.168.2.1/user كما تحدثنا عنها سابقا( شاهد الفيديو )

ولمسح سجلات المستخدمين للحفاظ على قاعدة البيانات لليوزر مانجر استخدم الامر التالي :

:local Flag
:set Flag [/tool user-manager log find] :if ([:len $Flag] > 0) do={/tool user-manager log print append file log;/tool user-manager log remove [/tool user-manager

طريقة أخرى لمسح السجلات  :

:log error "Clearing Data Base Logs ... It may take some time & CPU if Logs are huge in size......."
/tool user-manager database clear-log
:log warning "Data Base Cleared ... Now Rebuilding Data Base , It may take some time & CPU if Logs are huge in size......."
/tool user-manager database rebuild
:log warning "Data Base Rebuild Complete...."

شرح خادم Mikrotik PPPoE

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع  شرح خادم Mikrotik PPPoE لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

card-usermanger

انشاء قالب الكروت في اليوزرمانجر لطباعة الكروت علية

انشاء قالب الكروت في اليوزرمانجر : جميع من يعمل على اليوزر مانجر يستخدم قالب محدد …



Mohon Aktifkan Javascript!Enable JavaScript