البداية / مايكروتك / شيرينج وكاش / CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

أولا بعض نظرية DRY!

تقوم شبكات CDN بتكرار المحتوى في أماكن متعددة. هناك فرصة أفضل لأن يكون المحتوى أقرب من المستخدم ، مع عدد أقل من النقلات، وسيتم تشغيل المحتوى عبر شبكة أكثر سهولة.

الفكرة العامة لشبكة CDN هي تقديم المحتوى بأسرع ما يمكن للمستخدم دون المساس بتجربة المستخدم.

CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

عادة ، يكون لشبكة CDN خوادم مواقع عالمية ، تسمى نقطة الحضور. هذه PoPs تخزن البيانات كذاكرة التخزين المؤقت. عندما يطلب المستخدم موقع ويب ، فإن أقرب PoP سوف يتعامل مع الطلب باستخدام ذاكرة التخزين المؤقت المخزنة.

حاول اللاعبون الكبار مثل Google من أجل تحسين تجربة المستخدم الاقتراب من المستخدم قدر الإمكان من خلال النظرة المباشرة مع مزودي الخدمة الإقليميين وتوفير المحتويات باستخدام موفري CDN (شبكة توصيل المحتوى). تمتلك Google شبكة CDN الخاصة بها كخدمة تسمى Google Global Cache (GGC)

في الوقت الحاضر ، يمتلك جميع مزودي خدمة الإنترنت الرئيسيين خدمة CDN ، مما يساعدهم بشكل كبير على تقليل العبء على تغذية الإنترنت.

بدون CDN ، ستكون تكلفة النطاق الترددي الحقيقي للإنترنت عبئًا ثقيلًا على أي OP.

مع CDN ، سيحصل المستخدم على تجربة بث فيديو أفضل.

شخصيا أعرف القليل من مزودي خدمة الإنترنت هنا في كراتشي (وواحد نشأ بشكل خاص من منطقة جولشان) والذي يعتمد كليا على شبكة CDN (أكثر من 50-60 ٪ من بيانات الإنترنت تتجه عبر CDN) ، لقد استخدمت واحدة منها ، وهناك سرعة إنترنت حقيقية مثيره للشفقة ولكن إذا كنت تتصفح YT / FB فإنها تعمل بشكل ممتاز.

سيناريو:

مزود خدمة الإنترنت الأولي الخاص بنا مزود بخادم CDN مثبت في مركز البيانات ، وحركة المرور للبيانات المتجهة إلى CDN ليس لها حدود. لكننا نريد السيطرة على حركة المرور على النحو التالي :

حزمة 1 ميغابايت للمستخدمين تقسم للتحكم في عرض النطاق الترددي …

1MB عرض النطاق الترددي الإنترنت
عرض النطاق الترددي 1MB CDN

لذلك إذا كان المستخدم يتصفح الإنترنت ، فسوف يحصل على سرعة إنترنت كاملة قدرها 1 ميجابايت ، وإذا استخدم حركة المرور المتجهة إلى YOUTUBE CDN ، فسيحصل على 1 ميغابايت (إضافية).
تقريبا سوف تحصل على 2MB في المجموع.

باستخدام Mikrotik ، يمكننا تحقيق هذه المهمة باستخدام Firewall Mangle & Queues Tree.

يمكن القيام بنفس الشيء مع قوائم Mangle و PCQ الأساسية البسيطة أيضًا.

إنه موضوع قابل للنقاش حول ما يجب استخدامه ، ويعتمد على التحديد ، كما سيتم تغيير طريقة وضع علامات التمييز.

إخلاء المسئولية:

هذا مجرد مثال لأغراض المشاركة فقط ونعم ، فهناك العديد من الطرق وتقنيات الضبط الأخرى التي يمكنك اتباعها لجعل هذه العملية أكثر فاعلية.

اليكم السكربت المستخدم في هذي العمليه :

#===================================================
# CDN PACKET MARKING SCRIPT using Mangle/Queue.Tree
# By Syed.Jahanzaib
# Email: aacableAThotmailDOTcom
# https://aacableDOTwordpressDOTcom
# March 2019
#===================================================
# Address list name which is created dynamically by radius or you can go with manual method too
# This is important ... it can be done by varieties of ways, select one that matches your network design
#1Mb
#2Mb
 
#Create Address List which will contain CDN server's IP addresses
/ip firewall address-list
add address=1.2.3.4/24 list=cdn_list
add address=5.6.7.8/32 list=cdn_list
 
# Copy paste following rules & make sure to move these MANGLE rules to TOP position,
# so that they can be applied before any other rule, (for cdn)
 
/ip firewall mangle
add action=mark-packet chain=postrouting dst-address-list=cdn_list new-packet-mark=cdn_1mb_up passthrough=no src-address-list=1Mb
add action=mark-packet chain=postrouting dst-address-list=1Mb new-packet-mark=cdn_1mb_down passthrough=no src-address-list=cdn_list
 
add action=mark-packet chain=postrouting dst-address-list=cdn_list new-packet-mark=cdn_2mb_up passthrough=no src-address-list=2Mb
add action=mark-packet chain=postrouting dst-address-list=2Mb new-packet-mark=cdn_2mb_down passthrough=no src-address-list=cdn_list
 
# Define Queue Type & limitation that we want to provide to each package
/queue type
add kind=pcq name=1mb-cdn-download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=1024k pcq-src-address6-mask=64 pcq-total-limit=1024KiB
add kind=pcq name=1mb-cdn-upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=1024k pcq-src-address6-mask=64 pcq-total-limit=1024KiB
 
add kind=pcq name=2mb-cdn-download pcq-classifier=dst-address pcq-dst-address6-mask=64 pcq-rate=2048k pcq-src-address6-mask=64 pcq-total-limit=2048KiB
add kind=pcq name=2mb-cdn-upload pcq-classifier=src-address pcq-dst-address6-mask=64 pcq-rate=2048k pcq-src-address6-mask=64 pcq-total-limit=2048KiB
 
# Add Queue/Speed Limitation using above Queue Types to firewall mangled/marked packets
 
/queue tree
add name="CDN - 1mb - upload" packet-mark=cdn_1mb_up parent=global priority=1 queue=1mb-cdn-upload
add name="CDN - 1mb - download" packet-mark=cdn_1mb_down parent=global priority=1 queue=1mb-cdn-download
 
add name="CDN - 2mb - upload" packet-mark=cdn_2mb_up parent=global priority=1 queue=2mb-cdn-upload
add name="CDN - 2mb - download" packet-mark=cdn_2mb_down parent=global priority=1 queue=2mb-cdn-download
 
# Script Ends Here.

المستخدمين 1MB استخدام CDN الرسم البياني.

CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنتكما هو مبين في الصورة أعلاه ، يستخدم مستخدمو 1 ميغابايت 227 ميغابايت من عرض النطاق الترددي CDN (YT) ، (كان الوقت معطلاً مع عدد أقل من المستخدمين ، في ذروة حركة المرور تصل إلى غيغابايت) والنطاق الترددي الحقيقي للإنترنت مجاني أو متاح للمهام الأخرى / المستخدمين ، وبالتالي توفير تدفقات عرض النطاق الترددي للإنترنت الحقيقي.

أنتهى … CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

ملاحظة :

قد تكون المقالة محمية ضد النقل

وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع CDN traffic كيفية تخزين حركة مرور البيانات في الشبكة لسرعة التصفح وتوفير الانترنت لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

تشغيل الريسيفر على المايكروتك

طريقة تشغيل الريسيفر على سيرفر المايكروتك

طريقة تشغيل الريسيفر على سيرفر المايكروتك اليكم طريقة تشغيل الريسيفر على سيرفر المايكروتك بطريقة مبسطة …

اترك تعليقاً



Mohon Aktifkan Javascript!Enable JavaScript