البداية / مايكروتك / الوينبوكس / Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

يقدم مزود الخدمة اتصالات Ethernet للعملاء ويقول:

“هذا الاتصال ينتقل إلى الموقع A ، هذا الاتصال الآخر ينتقل إلى الموقع B ، لديك مقدار X من النطاق الترددي ، افعل به ما تشاء”.

ليس العميل بحاجة إلى أي فكرة عن كيفية عمله على الواجهة الخلفية.

فهو يجعل من الربط الشبكي للمواقع البعيدة أسهل بكثير وبالنسبة للعميل فهي قيمة مضافة .

من الواضح أن هناك الكثير من الطرق الأخرى لشبك وربط المواقع البعيدة معا.

مثلا هناك :

EoIP ، GRE ، IPSEC ، GRE مع IPSEC ، وإذا كان لديك Scrooge McDuck والكثير من المال فيمكنك تشغيل الألياف الخاصة بك أيضا.

ومع ذلك ، فإن :

MPLS شائعة الاستعمال للغاية مقارنة بالحلول الأخرى لأنها شفافة بالنسبة للعميل ، وليس على العميل اي إدارة للـ tunnels، وكلها جاهزة بشكل كامل.

لهذا كنت أرغب في معرفة ما يجري وراء الستار :mrgreen:  ، وما يتطلبه الأمر بالفعل لتوفير هذه الانفاق او tunnels، وهكذا فعلت.

قبل أن نذهب إلى أبعد من ذلك ، يجب أن تكون على دراية ببعض المصطلحات ، وأقترح أن تقرأ عن MPLS الأساسية :

هناك فصلين دراسيين هما LSR و LER ، أو Label Switch Router و Label Edge Router على التوالي.

LSR هو جهاز توجيه يقوم بتشغيل MPLS يقوم فقط بتشغيل تحويل التسمية في core ؛ لا يضيف أو يزيل التصنيفات عند دخول الشبكة أو الخروج.

LER هو جهاز توجيه يقوم بتشغيل MPLS يدفع (يضيف) أو ينبثق (يزيل) تسمية MPLS عندما تدخل الحزمة أو تخرج من شبكة MPLS.

تتواجد LSRs في core، وتوجد LERs على edge.

توضح هذه المقالة كيفية إعداد شبكة MPLS أساسية  ، يدعمها OSPF ، وتشغيل أنفاق VPLS tunnels عبر هذا المركز الأساسي بين مواقع العملاء.

ويتيح لك ذلك منح العميل عملية إيثرنت على جانبي النفق tunnels ، وأخبارهم بشكل أساسي أن يتظاهروا بأنه مربوط بكابل Cat6 بين المواقع :mrgreen: .

إليك السينياريو الذي نعمل معه ، مع وجود جهازين للعميل متصلان بجهاز توجيه موفر من Seattle و Santa Fe:

Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

يريد العميل أن يكون قادرًا على الاتصال بالأجهزة في Santa Fe من سياتل كما لو كانت أجهزة محلية.

يتم بالفعل تكوين عناوين IP على واجهات Ethernet .

أولاً سنقوم بإعداد أجهزة التوجيه الأساسية في سياتل ، و Santa Fe ، وأتلانتا ، مما يؤدي إلى إنشاء عمليات الاسترجاع ، ثم الحصول على OSPF ، ثم MPLS مع LDP.

سيتم تشغيل VPLS فوق كل ذلك. سوف يعطينا OSPF بعض المرونة إذا فشل الارتباط ، مثل بين LSRs سياتل و Santa Fe.

على سياتل LSR:

ملاحظة قد تكون المقالات محمة ضد النقل وبالتالي لنسخ الاكواد انقر على علامة + باعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"

/routing ospf instance set [ find default=yes ] router-id=72.156.28.150

/routing ospf network
add area=backbone network=72.156.28.0/30
add area=backbone network=72.156.28.8/30
add area=backbone network=72.156.28.150/32
add area=backbone network=72.156.29.0/24

 /mpls interface
set [ find default=yes ] interface=ether1 
add interface=ether2
add interface=ether3

/mpls ldp set enabled=yes lsr-id=72.156.28.150 transport-address=72.156.28.150

/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

/mpls ldp neighbor
add transport=72.156.28.151
add transport=72.156.28.152
add transport=72.156.29.120

على Santa Fe LSR:

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"

/routing ospf instance set [ find default=yes ] router-id=72.156.28.151

/routing ospf network
add area=backbone network=72.156.28.8/30
add area=backbone network=72.156.28.4/30
add area=backbone network=72.156.30.0/24
add area=backbone network=72.156.28.151/32

/mpls interface
set [ find default=yes ] interface=ether2
add interface=ether3
add interface=ether1

/mpls ldp set enabled=yes lsr-id=72.156.28.151 transport-address=72.156.28.151

/mpls ldp interface
add interface=ether1
add interface=ether2
add interface=ether3

/mpls ldp neighbor
add transport=72.156.28.150
add transport=72.156.28.152
add transport=72.156.30.120

على أتلانتا LSR:

/interface bridge add comment="MPLS Loopback" name="MPLS Loopback"

/routing ospf instance set [ find default=yes ] router-id=72.156.28.152

/routing ospf network
add area=backbone network=72.156.28.0/30
add area=backbone network=72.156.28.4/30
add area=backbone network=72.156.28.152/32

/mpls interface
set [ find default=yes ] interface=ether1
add interface=ether3

/mpls ldp set enabled=yes lsr-id=72.156.28.152 transport-address=72.156.28.152

/mpls ldp interface
add interface=ether1
add interface=ether3

/mpls ldp neighbor
add transport=72.156.28.150
add transport=72.156.28.151

عند هذه النقطة لدينا OSPF تعمل في core، و MPLS يعمل كذلك على أجهزة التوجيه LSR.

من هذه النقطة سنركز على LERs التي ترتبط فعليًا بالعملاء. سنقوم بإضافة bridge إضافي لحركة VPLS ، وتكوين OSPF و MPLS مع LDP على كل LERs ، ثم سننتقل إلى بناء VPLS tunnels.

على سياتل LER:

/interface bridge
add comment="MPLS Loopback" name="MPLS Loopback"
add comment="Customer #4306 Site 1" name="VPLS Customer 4306-1 Bridge"

/routing ospf instance set [ find default=yes ] router-id=72.156.29.120

/routing ospf network
add area=backbone network=72.156.29.0/24
add area=backbone network=72.156.29.120/32

/mpls interface set [ find default=yes ] interface=ether3

/mpls ldp set enabled=yes lsr-id=72.156.29.120 transport-address=72.156.29.120

/mpls ldp interface add interface=ether3

/mpls ldp neighbor add transport=72.156.28.150

علىSanta Fe LER :

/interface bridge
add comment="MPLS Loopback" name="MPLS Loopback"
add comment="Customer #4306 Site 2" name="VPLS Customer 4306-2 Bridge"

/routing ospf instance set [ find default=yes ] router-id=72.156.30.120

/routing ospf network
add area=backbone network=72.156.30.0/24
add area=backbone network=72.156.30.120/32

/mpls interface set [ find default=yes ] interface=ether1

/mpls ldp set enabled=yes lsr-id=72.156.30.120 transport-address=72.156.30.120

/mpls ldp interface add interface=ether1

/mpls ldp neighbor add transport=72.156.28.151

عند هذه النقطة يجب أن يكون :

OSPF متقاربًا بالكامل ، وفي علامة التبويب MPLS Bindings يجب أن نرى بعض تسميات MPLS المرتبطة بعناوين الوجهة:

Mikrotik MPLS with VPLS

يجب أن نرى أيضًا بعض الإدخالات في جدول إعادة التوجيه:

 Mikrotik MPLS Forwarding Table

هذا هو MPLS في العمل ، وربط المسارات مع تسميات للبحث السريع 

وهو ما يعطي MPLS تعزيز أداء العلامة التجارية الخاصة بها عبر توجيه IP المنتظم من طرف إلى طرف.

نحن مستعدون الآن لإضافة VPLS tunnels والبدء في نقل بعض الزيارات بشفافية بين المواقع.

سيتم استخدام bridge interfaces الإضافية التي أضفناها على LERs من أجل بريدج واجهات VPLS الافتراضية مع واجهات الإيثرنت المادية التي نسلمها إلى الزبون.

على سياتل LER:

/interface vpls
add comment="Customer 4306-2 VPLS" disabled=no l2mtu=1500 name="Customer 4306-2 VPLS" remote-peer=72.156.30.120 vpls-id=90:0

/interface bridge port
add bridge="VPLS Customer 4306-1 Bridge" interface=ether1
add bridge="VPLS Customer 4306-1 Bridge" interface="Customer 4306-2 VPLS"

علىSanta Fe LER :

/interface vpls
add comment="Customer 4306-1 VPLS" disabled=no l2mtu=1500 name="Customer 4306-1 VPLS" remote-peer=72.156.29.120 vpls-id=90:0

/interface bridge port
add bridge="VPLS Customer 4306-2 Bridge" interface=ether3
add bridge="VPLS Customer 4306-2 Bridge" interface="Customer 4306-1 VPLS"

في هذه المرحلة ، أنشأنا اتصالًا من المستوى الثاني بين كل ما يتم توصيله بـ ether1 في سياتل و ether3 في Santa Fe.

يمكن للعميل رمي أجهزة التوجيه على تلك الاتصالات ، أو التبديل ، أو توصيل الخوادم مباشرة.

لأغراض العرض ، أضع خادم أوبونتو الظاهري على كل من تلك الواجهات المادية ، مع إعطائهم عناوين IP 10.2.2.1 و 10.2.2.2 ،

وتشغيل iperf كلا الاتجاهين لاختبار النطاق الترددي كما هو موضح أدناه:

 Mikrotik MPLS IPerf Testing

يُظهر اختبار النطاق الترددي اتصالًا متسقًا وسريعًا.

هذه الشبكة والخوادم كلها ظاهرية :

لذلك في حين أنها لا تعمل بسرعة سلك gigabit فإنها لا تزال تعمل بشكل جيد.

أحد المتطلبات الأخرى لهذا الحل هو عدم وجود قفزات بين الموقعين – يجب أن يكون هذا شفافًا للعميل.

يوضح التتبع من 10.2.2.2 إلى 10.2.2.1 ما يلي:

 Mikrotik MPLS Traceroute

أنتهى … Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع Mikrotik MPLS مع VPLS وكيفية استخدامه في عمليات الربط بين الشبكات لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

mikrotik config ستساعدك هذه الأدوات في إنشاء عدة إعدادات أساسية لـ MikroTik RouterOS

mikrotik config ستساعدك هذه الأدوات في إنشاء عدة إعدادات أساسية لـ MikroTik RouterOS ستساعدك هذه …



Mohon Aktifkan Javascript!Enable JavaScript