البداية / مايكروتك / الوينبوكس / كيفية انشاء خادم MIKROTIK OPEN OVPN SERVER اليكم شرح بالتفصيل

كيفية انشاء خادم MIKROTIK OPEN OVPN SERVER اليكم شرح بالتفصيل

MIKROTIK OPEN OVPN SERVER

اليكم  الخطوات التي يمكن استخدامها لإنشاء OVPN server باستخدام جهاز Mikrotik router.

في هذا المثال ، سنستخدم جهاز راوتر مع IP 192.168.88.2 الخارجي ، و IP 192.168.89.1 داخليًا ، وسيكون الكلاينت الخاص بمجموعة OVPN 192.168.87.0/24.

1- إنشاء وتوقيع الشهادات:

سوف تحتاج إلى تشغيل الأمر التالي واحدًا تلو الآخر ، وسيتطلب توقيع الشهادات وقتًا وسيحمّل وحدة المعالجة المركزية.
لاحظ أنه في بعض الأحيان ستحصل على خطأ “انقضاء وقت العمل” عندما تقوم بتوقيع الشهادات ، وهذا ليس مشكلة ، عليك فقط الانتظار لفترة أطول قليلا.

MIKROTIK OPEN OVPN SERVER

يمكنك أن ترى أن جهاز الراوتر مشغول بعلامة الشهادة ويستهلك ذلك من استخدام وحدة المعالجة المركزية ، عندما يتم توقيع الشهادة فسوف ينخفض استخدام وحدة المعالجة المركزية وسوف ترى “KLAT” في وصف سطر شهادة CA و “KI” في الخادم وشهادة العميل ، بعد الانتهاء من توقيع الشهادة ، يمكنك متابعة الشهادة التالية.

/certificate add name=CA country="RO" state="RO" locality="Bucharest" organization="home" unit="mk" common-name="CA" key-size=4096 days-valid=3650 key-usage=crl-sign,key-cert-sign
/certificate sign CA ca-crl-host=127.0.0.1 name="CA"

/certificate add name=server country="RO" state="RO" locality="Bucharest" organization="home" unit="mk" common-name="server" key-size=4096 days-valid=3650 key-usage=digital-signature,key-encipherment,tls-server
/certificate sign server ca="CA" name="server"

/certificate add name=client country="RO" state="RO" locality="Bucharest" organization="home" unit="mk" common-name="client" key-size=4096 days-valid=3650 key-usage=tls-client
/certificate sign client ca="CA" name="client"

/certificate add name=client1 copy-from="client" common-name="client1"
/certificate sign client1 ca="CA" name="client1"

2- تصدير وتنزيل الشهادات والمفتاح:

/certificate export-certificate CA export-passphrase=""
/certificate export-certificate client1 export-passphrase=12345678

احفظ الملفات التي تم تصديرها إلى جهاز الكمبيوتر الخاص بك.

download_certificates

قم بإزالة “cert_export_” من اسم الشهادة ، بعد أن يكون لديك 3 ملفات: “CA.crt” ، “cleint1.crt” ، “cleint1.key” “هذا ليس مهمًا جدًا لكن اسم الملف الطويل يزعج  😆 “.

3- توقيع المفتاح العام:

قم بتثبيت OVPN على جهاز الكمبيوتر الخاص بك وتأكد من التحقق من “EasyRSA 2 Script Management Script”.

ovpn_install

افتح موجه الأوامر ، وانتقل إلى الموقع الذي حفظت فيه الملفات وقم بتشغيله:

"C:\Program Files\OpenVPN\bin\openssl.exe" rsa -in client1.key -out client1.key

سيطلب منك: “إدخال عبارة المرور لـ client1.key” ، يمكنك تعيين عبارة المرور عند تصدير الشهادات ، في هذا المثال ، عبارة المرور هي: “12345678”.

4- قم بتعيين خادم OVPN على الموجه:

إنشاء POOL جديد لخادم ovpn:

/ip pool
add name=ovpn ranges=192.168.87.30-192.168.87.254
/ip dhcp-server network
add address=192.168.87.0/24 comment=vpn dns-server=192.168.89.1 gateway=\
192.168.89.1 netmask=24

تكوين SERVER OVPN:

/ppp profile
add bridge=bridge dns-server=192.168.89.1 local-address=ovpn name=open_vpn \
remote-address=ovpn use-compression=no use-encryption=required
/interface ovpn-server server
set certificate=server cipher=blowfish128,aes128,aes192,aes256 default-profile=open_vpn enabled=yes \
require-client-certificate=yes

إضافة اسم مستخدم وكلمة مرور لـ OVPN Client:-

/ppp secret
add name=client1 password=password1 profile=open_vpn service=ovpn

إضافة استثناء OVPN إلى firewall جدار الحماية:

/ip firewall filter
add action=accept chain=input comment=VPN dst-port=1194 protocol=tcp

أنت الآن جاهز ويمكنك الاتصال بخادم OVPN الخاص بك.

لاختبار الخادم ، بالإضافة إلى الشهادات والمفتاح ، استخدمت test.ovpn و auth.cfg.

MIKROTIK OPEN OVPN SERVER

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم كيفية انشاء خادم MIKROTIK OPEN OVPN SERVER

والذي نتمنى ان ينال رضاكم واعجابكم

والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع كيفية انشاء خادم MIKROTIK OPEN OVPN SERVER لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager

دخول المستخدم تلقائي بواسطة MAC وإعادة التوجيه باستخدام Radius Manager تمكين المستخدمين المحددين تسجيل الدخول …



Mohon Aktifkan Javascript!Enable JavaScript