البداية / مايكروتك / رولات وسكربتات / Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

يمكن للجدولة Scheduler  تشغيل وتنفيذ السكربتات في لحظة زمنية معينة ، بعد فترة زمنية محددة ، أو كليهما معا.

فكثيرا مانسمع عن قائمة Scheduler ونقوم باعطاء بعض المهام لها ولاكن الكثير لايعلم عنها وعن مهامها او خصائصها الا الشي اليسير

Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

الخصائص :

interval : (الوقت ؛ الافتراضي: 0s) – الفاصل الزمني بين تنفيذين للسكربت ، إذا تم تعيين الفاصل الزمني على صفر ، يتم تنفيذ السكربت فقط في وقت البدء ، وإلا يتم تنفيذه بشكل متكرر في الفترة الزمنية المحددة .

name :اسم) – اسم المهمة

on-event : (الاسم) – اسم البرنامج النصي المطلوب تنفيذه. يجب تقديمه فيsystem script

run-count : (للقراءة فقط: عدد صحيح) – لمراقبة استخدام السكربت ، يتم زيادة هذا العداد في كل مرة يتم فيها تنفيذ البرنامج النصي

start-date : (التاريخ) – تاريخ تنفيذ السكربت الأول

start-time : (الوقت) – وقت تنفيذ السكربت الأول

startup : – تنفيذ السكربت بعد 3 ثوانٍ من بدء تشغيل النظام.

ملاحظات :

إعادة تشغيل جهاز الميكروتك سيعيد تعيين عداد التشغيل.

إذا كان يجب تنفيذ أكثر من سكربت في نفس الوقت ، فسيتم تنفيذها بالترتيب الذي تظهر به في اعداد scheduler . يمكن أن يكون هذا مهمًا إذا تم استخدام أحد السكربتات المجدولة لتعطيل سكربتات آخرى.

إذا كان هناك حاجة لنمط تنفيذ أكثر تعقيدًا ، فيمكن إجراؤه عادة عن طريق جدولة العديد من السكربتات ، وجعلها تمكّن وتعطل بعضها البعض.

ملاحظة: إذا تم تعيين بدء تشغيل عنصر جدولة وقت التشغيل ، فإنه يتصرف كما لو تم تعيين وقت البدء وتاريخ البدء إلى الوقت 3 ثوانٍ بعد بدء تشغيل وحدة التحكم. يعني ذلك أن جميع السكربتات التي تحتوي على وقت بدء التشغيل هي بدء التشغيل ، وسيتم تنفيذ الفاصل الزمني 0 مرة واحدة في كل مرة يقوم فيها جهاز التوجيه بالتمهيد. إذا تم تعيين الفاصل الزمني لقيمة أخرى غير جدولة 0 لن يعمل عند بدء التشغيل

أمثلة :

سنضيف مهمة تقوم بتنفيذ اختبار سجل السكربت كل ساعة:

ملاحظة :

قد تكون المقالة محمية ضد النقل وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

[[email protected]] system script> add name=log-test source=:log message=test
[[email protected]] system script> print
    0 name="log-test" source=":log messgae=test" owner=admin run-count=0
[[email protected]] system script> .. scheduler
[[email protected]] system scheduler> add name=run-1h interval=1h
on-event=log-test
[[email protected]] system scheduler> print

Flags: X - disabled
 #   NAME      ON-EVENT  START-DATE  START-TIME INTERVAL     RUN-COUNT
 0   run-1h    log-test  mar/30/2004 06:11:35   1h           0
[[email protected]] system scheduler>

في مثال آخر ، سيكون هناك عدد 2 سكربتات مضافان سيؤديان إلى تغيير إعداد النطاق الترددي queue rule “Cust0”. كل يوم في الساعة 9 صباحاً ، سيتم ضبط قائمة queue على 64 كيلوبت / ثانية وفي الساعة 5 مساءً سيتم ضبط قائمة queue على 128 كيلوبت / ثانية. queue rule, scripts, ومهام scheduler أدناه:

[[email protected]] queue simple> add name=Cust0 interface=ether1 \
\... dst-address=192.168.0.0/24 limit-at=64000
[[email protected]] queue simple> print
Flags: X - disabled, I - invalid
  0   name="Cust0" target-address=0.0.0.0/0 dst-address=192.168.0.0/24
      interface=ether1 limit-at=64000 queue=default priority=8 bounded=yes

[[email protected]] queue simple> /system script
[[email protected]] system script> add name=start_limit source={/queue simple set \
\... Cust0 limit-at=64000}
[[email protected]] system script> add name=stop_limit source={/queue simple set \
\... Cust0 limit-at=128000}
[[email protected]] system script> print
  0 name="start_limit" source="/queue simple set Cust0 limit-at=64000"
    owner=admin run-count=0

  1 name="stop_limit" source="/queue simple set Cust0 limit-at=128000"
    owner=admin run-count=0

[[email protected]] system script> .. scheduler
[[email protected]] system scheduler> add interval=24h name="set-64k" \
\... start-time=9:00:00 on-event=start_limit
[[email protected]] system scheduler> add interval=24h name="set-128k" \
\... start-time=17:00:00 on-event=stop_limit
[[email protected]] system scheduler> print
Flags: X - disabled
  #   NAME      ON-EVENT START-DATE  START-TIME INTERVAL             RUN-COUNT
  0   set-64k   start... oct/30/2008 09:00:00   1d                   0
  1   set-128k  stop_... oct/30/2008 17:00:00   1d                   0
[[email protected]] system scheduler>

يقوم المثال التالي بجدولة سكربت يرسل كل أسبوع نسخة احتياطية من تكوين جهاز الميكروتك عن طريق البريد الإلكتروني.

[[email protected]] system script> add name=e-backup source={/system backup
{... save name=email; /tool e-mail send to="[email protected]" subject=([/system
{... identity get name] . " Backup") file=email.backup}
[[email protected]] system script> print
  0 name="e-backup" source="/system backup save name=ema... owner=admin
    run-count=0

[[email protected]] system script> .. scheduler
[[email protected]] system scheduler> add interval=7d name="email-backup" \
\... on-event=e-backup
[[email protected]] system scheduler> print
Flags: X - disabled
  #   NAME      ON-EVENT START-DATE  START-TIME INTERVAL             RUN-COUNT
  0   email-... e-backup oct/30/2008 15:19:28   7d                   1
[[email protected]] system scheduler>

لا تنسى ضبط إعدادات البريد الإلكتروني ، مثل خادم SMTP وعنوان من: عنوان / تحت البريد الإلكتروني للأداة.

فمثلا:

[[email protected]] tool e-mail> set server=159.148.147.198 [email protected]
[[email protected]] tool e-mail> print
    server: 159.148.147.198
      from: [email protected]
[[email protected]] tool e-mail>

سيضع المثال أدناه “x” في السجلات كل ساعة من منتصف الليل حتى الظهر:

[[email protected]] system script> add name=enable-x source={/system scheduler
{... enable x}
[[email protected]] system script> add name=disable-x source={/system scheduler
{... disable x}
[[email protected]] system script> add name=log-x source={:log message=x}
[[email protected]] system script> .. scheduler
[[email protected]] system scheduler> add name=x-up start-time=00:00:00 \
\... interval=24h on-event=enable-x
[[email protected]] system scheduler> add name=x-down start-time=12:00:00
\... interval=24h on-event=disable-x
[[email protected]] system scheduler> add name=x start-time=00:00:00 interval=1h \
\... on-event=log-x
[[email protected]] system scheduler> print
Flags: X - disabled
  #   NAME      ON-EVENT START-DATE  START-TIME INTERVAL             RUN-COUNT
  0   x-up      enable-x oct/30/2008 00:00:00   1d                   0
  1   x-down    disab... oct/30/2008 12:00:00   1d                   0
  2   x         log-x    oct/30/2008 00:00:00   1h                   0
[[email protected]] system scheduler>

انتهىى … Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

ملاحظة :

قد تكون المقالة محمية ضد النقل وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع Scheduler الجدولة في الميكروتك كيف تتم وماهي خصائصها ومهامها في السيرفر لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك المشكلة : كنت ترغب …



Mohon Aktifkan Javascript!Enable JavaScript