البداية / مايكروتك / راوتربورد مايكروتك / Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

ملخص

WebFig هي أداة RouterOS تعتمد على الويب والتي تتيح لك مراقبة جهاز التوجيه وتكوينه واستكشاف أخطائه وإصلاحها.

تم تصميمه كبديل لـ WinBox ، وكلاهما لهما تخطيطات متشابهة وكلاهما يتمتعان بإمكانية الوصول إلى أي ميزة تقريبًا في RouterOS.يمكن الوصول إلى WebFig مباشرة من جهاز الراوتر مما يعني أنه لا توجد حاجة لتثبيت برامج إضافية (باستثناء متصفح الويب مع دعم JavaScript ، بالطبع).

نظرًا لأن Webfig عبارة عن نظام أساسي مستقل ، فيمكن استخدامه لتكوين جهاز الميكروتك مباشرة من الأجهزة المحمولة المختلفة دون الحاجة إلى برنامج تم تطويره لمنصة معينة.

بعض المهام التي يمكنك تنفيذها مع WebFig:

  • التكوين – عرض وتحرير التكوين الحالي ؛
  • المراقبة – عرض الحالة الحالية للموجه ، ومعلومات التوجيه ، وإحصائيات الواجهة ، والسجلات وغيرها الكثير .
  • استكشاف الأخطاء وإصلاحها – قام جهاز الراوتر (RouterOS) ببناء العديد من أدوات استكشاف الأخطاء وإصلاحها (مثل ping و traceroute و sniffers للحزم ومولدات المرور وغيرها الكثير) ويمكن استخدامها جميعًا مع WebFig.

الاتصال بجهاز التوجيه :

يمكن إطلاق WebFig من صفحة أجهزة التوجيه الرئيسية والتي يمكن الوصول إليها عن طريق إدخال عنوان IP الخاص بالموجهات في المستعرض. عند تحميل الصفحة الرئيسية بنجاح ، اختر webfig من قائمة الرموز المتاحة كما هو موضح في لقطة الشاشة.


Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها
بعد النقر على رمز webfig ، سيطلب منك تسجيل الدخول بإدخال اسم المستخدم وكلمة المرور. أدخل معلومات تسجيل الدخول وانقر فوق الاتصال.

الآن يجب أن تكون قادرا على رؤية webfig في بيئة العمل :mrgreen:

اتصال IPv6 :

خدمة HTTP RouterOS متاحة الآن على عنوان ipv6 ، أيضا. للاتصال بـ IPv6 ، أدخل في متصفحك عنوان ipv6 بين قوسين مربعين ، على سبيل المثال [2001: db8: 1 :: 4].

إذا كان مطلوبًا من الرابط ربط العنوان المحلي ، فلا تنس تحديد اسم interface أو معرف الواجهة على النوافذ ، على سبيل المثال [fe80 :: 9f94: 9396٪ ether1].

تمكين HTTPS :

بشكل افتراضي يتم تعطيل الوصول إلى جهاز الراوتر باستخدام HTTPS ، ولكن يمكن تمكينه إذا كان لديك شهادة صالحة.

في حال لم يكن لديك شهادة صالحة ، يمكنك إنشاء الخاصة بك باستخدام RouterOS. لإنشاء شهاداتك الخاصة وتمكين وصول HTTPS ، يجب عليك أولاً تسجيل الدخول إلى الراوتر باستخدام Webfig (إصدار HTTP أو يمكنك استخدام Winbox أو SSH أو Telnet) وفتح terminal جديدة وإدخال الأوامر التالية:

قم بإنشاء root CA الخاص بك على جهاز الميكروتك الخاص بك :

/certificate
add name=LocalCA common-name=LocalCA key-usage=key-cert-sign,crl-sign

قم بتوقيع شهادة CA المنشأة حديثًا :

/certificate
sign LocalCA

ملاحظة:

في حالة قيامك بالفعل بإعداد المرجع المصدق الخاص بك أو كنت تستخدم خدمة تقوم بتوقيع الشهادات نيابة عنك ، فإنك تقوم بإنشاء الشهادة والتوقيع عليها عن بُعد واستيراد الشهادة على جهاز التوجيه لاحقًا.

إذا كنت تستورد شهادة ، فتأكد من تمييز الشهادة على أنها موثوق بها.

إنشاء شهادة جديدة لـ Webfig (شهادة غير جذر) :

/certificate
add name=Webfig common-name=192.168.88.1

ملاحظة:

ستواجة معظم المتصفحات خطأ شهادة غير صالح إذا كان الاسم الشائع للشهادة لا يتطابق مع العنوان الذي تزوره ، ولهذا السبب يمكنك تحديد عنوان IP الخاص بالموجه كاسم شائع حيث أنك ستستخدم عنوان IP فتح Webfig.

التوقيع على شهادة تم إنشاؤها حديثا ل Webfig :

/certificate
sign Webfig ca=LocalCA

ملاحظة:

لا يلزم تعيين الشهادة على أنها موثوق بها إذا قمت بإنشاء المرجع المصدق الجذري الخاص بك على نفس جهاز التوجيه منذ ذلك الحين بشكل افتراضي سوف يثق RouterOS في CA الخاص به ، وبالتالي سيثق في جميع الشهادات الموقعة من قبله ، بما في ذلك الشهادة التي تم إنشاؤها حديثًا Webfig.

تمكين www-ssl وتحديد لاستخدام الشهادة التي تم إنشاؤها حديثا ل Webfig :

/ip service
set www-ssl certificate=Webfig disabled=no

يمكنك الآن زيارة https://192.168.88.1 وتكوين جهاز الميكروتك بأمان.

ملاحظة:

لن تثق المتصفحات الافتراضية بالشهادات الموقعة ذاتيًا ، وستحتاج إلى إضافة الشهادة كموثوق بها في المرة الأولى التي تزور فيها الصفحة في متصفحك.

هناك أسلوب آخر يتمثل في تصدير شهادة المرجع المصدق الجذر واستيرادها كجذر موثوق به على جهاز الكمبيوتر الخاص بك ، وبهذه الطريقة سيتم اعتبار جميع الشهادات الموقعة من قبل هذا الموجب صحيحة وستسهل إدارة الشهادات في شبكتك.

نظرة عامة للواجهة:

تم تصميم واجهة WebFig لتكون بديهية للغاية خاصة بالنسبة لمستخدمي WinBox. لديها تخطيط مشابه جدا: شريط القائمة على الجانب الأيسر ، التراجع / الإعادة في الأعلى والعمل في بقية المساحة المتاحة.

Interface Overview

عند الاتصال بالراوتر ، يعرض شريط عنوان المستعرضات (اسم علامة التبويب في Chrome) القائمة المفتوحة حاليًا واسم المستخدم للمصادقة وعنوان IP وهوية النظام وإصدار ROS ونموذج جهاز التوجيه في التنسيق التالي:

[menu] at [username]@[Router's IP] ( [RouterID] ) - Webfig [ROS version] on [RB model] ([platform])

شريط القوائم لديه نفس تصميم شريط القوائم WinBox.

يشير السهم الصغير على الجانب الأيمن من عنصر القائمة إلى أن هذه القائمة تحتوي على عدة قوائم فرعية.

Webfig-submenu

عند النقر فوق عنصر القائمة هذا ، سيتم سرد القوائم الفرعية وسيوجه السهم لأسفل ، مشيرًا إلى أن القوائم الفرعية مدرجة.

في الأعلى ، يمكنك رؤية ثلاثة أزرار شائعة أزرار التراجع / الإعادة مشابهة لـ winbox وزر إضافي واحد تسجيل الخروج.

في الركن العلوي الأيسر ، يمكنك رؤية شعار WebFig واسم الطراز RouterBOARDS.

منطقة العمل لديها تصميم وعلامة تبويب ، حيث يمكنك التبديل بين عدة علامات تبويب التكوين ، على سبيل المثال في لقطة الشاشة يتم سرد كافة علامات التبويب المتوفرة في القائمة بريدج (Bridge, Ports, Filters, NAT, Rules).

أسفل علامات التبويب ، يتم عرض الأزرار المدرجة لجميع أوامر القائمة الخاصة ، على سبيل المثال إضافة إعدادات جديدة.

الجزء الأخير هو جدول جميع عناصر القائمة. يحتوي العمود الأول من عنصر على أزرار أوامر خاصة بكل عنصر:

- تمكين البند الحالي– تمكين البند الحالي

- تعطيل البند الحالي– تعطيل البند الحالي

- إزالة العنصر الحالي– إزالة العنصر الحالي

تكوين العنصر :

عند النقر على أحد العناصر المدرجة ، سيعمل webfig على فتح صفحة جديدة تعرض جميع المعلمات القابلة للتكوين ، والأوامر والحالات الخاصة بالعنصر.

Item configurationWebfig الدخول على الميكروتك

في الأعلى ، يمكنك مشاهدة نوع العنصر واسم العنصر.

في لقطة الشاشة على سبيل المثال ، يمكنك مشاهدة هذا العنصر عبارة عن واجهة مع تجاوز الاسم

هناك أيضا أزرار الأوامر عنصر محدد (موافق ، إلغاء ، تطبيق ، إزالة و Torch ). هذه يمكن أن تختلف بين عناصر مختلفة. على سبيل المثال Torch متاحة فقط للواجهات.

أزرار العنصر الشائعة:

حسنًا – تطبيق التغييرات على المعلمات والخروج ؛
إلغاء – الخروج وعدم تطبيق التغييرات ؛
تطبيق – تطبيق التغييرات والبقاء على الصفحة الحالية ؛
إزالة – قم بإزالة العنصر الحالي.

يعرض شريط الحالة المشابه لـ winbox الحالة الحالية للأعلام المحددة للبند (على سبيل المثال ، علامة تشغيل). علم التدرج الرمادي يعني أنه غير نشط. في لقطة الشاشة على سبيل المثال ، يمكنك أن ترى أن التشغيل باللون الأسود الصلب و slave رمادي ، مما يعني أن الواجهة قيد التشغيل وليست slave interface.

يتم تقسيم قائمة الخصائص في عدة أقسام ، على سبيل المثال “General”, “STP”, “Status”, “Traffic”.

في winbox ، توجد هذه الأقسام في علامات تبويب منفصلة ، ولكن يسرد Webfig كل ذلك في صفحة واحدة تحدد اسم القسم.

في screenshot يمكنك الاطلاع على قسم “General”. تعني خصائص Gray-edout وأنها للقراءة فقط وأن التكوين غير ممكن.

العمل مع الملفات :

يسمح Webfig بتحميل الملفات مباشرة إلى الراوتر ، دون استخدام خدمات FTP.

لتحميل الملفات ، افتح قائمة Files ، وانقر على زر اختيار ملف ، واختيار الملف والانتظار حتى يتم تحميل الملف.

 upload files directly to the routerWebfig الدخول على الميكروتك

يمكن أيضًا تنزيل الملفات بسهولة من جهاز التوجيه ، من خلال النقر على زر التنزيل على الجانب الأيسر من إدخال الملف.

Webfig-downloadWebfig الدخول على الميكروتك

Skins :

واجهات Webfig هي أداة مفيدة لجعل الواجهة أكثر سهولة في الاستخدام. إنها ليست أداة أمنية.

إذا كان لدى المستخدم حقوق كافية ، فمن الممكن الوصول إلى الميزات المخفية بوسائل أخرى.

تصميم skins :

إذا كان لدى المستخدم أذونات كافية (المجموعة لديها أذونات تحرير النهج) يصبح الزر Design Skin متاحًا. يؤدي الضغط على زر التبديل إلى فتح خيارات تحرير الواجهة.

العمليات المحتملة هي:

  • Hide menu هذا سوف يخفي كافة العناصر من القائمة والقوائم الفرعية الخاصة به .
  • Hide submenu سيتم إخفاء قائمة فرعية معينة فقط
  • Hide tabs إذا كانت تفاصيل القائمة الفرعية تحتوي على عدة علامات تبويب ، فمن الممكن إخفاؤها بهذه الطريقة
  • Rename menus, items جعل بعض الخصائص أكثر وضوحًا أو تترجمها إلى لغتك
  • Add note to to item (in detail view) لإضافة تعليقات
  • Make item read-only (in detail view) لسلامة المستخدم يمكن إجراء حقول حساسة للغاية للقراءة فقط
  • Hide flags (in detail view) في حين أنه من الممكن فقط إخفاء العلامة في عرض التفاصيل ، فإن هذه العلامة لن تكون مرئية في عرض القائمة وفي العرض التفصيلي
  • Add limits for field (في عرض التفاصيل) حيث توجد قائمة بالأوقات التي تكون فيها فاصلة أو قائمة مفصولة بالخطأ الجديد للقيم المسموح بها:
    number interval ‘..’ المثال: 1..10 سيسمح بالقيم من 1 إلى 10 للملفات ذات الأعداد ، على سبيل المثال ، حجم MTU.field prefix (حقول نصية ، عنوان MAC ، تعيين الحقول ، مربعات التحرير والسرد). إذا كان مطلوبًا للحد من طول البادئة ، فيجب إضافة $ إلى النهاية ، على سبيل المثال ، سيؤدي تحديد الواجهة اللاسلكية إلى “محطة” فقط إلى احتواء
  • Add Tab سيضيف شريطًا رماديًا مع تصنيف قابل للتعديل سيفصل بين الحقول. ستتم إضافة الشريط قبل الحقل الذي تمت إضافته إليه
  • Add Separator سيضيف فاصل أفقي منخفض الارتفاع قبل الحقل الذي تتم إضافته إليه.

ملاحظة:

لا يمكن تعيين عدد الفواصل الزمنية لتوسيع القيود التي تم تعيينها بواسطة RouterOS لهذا الحقل

ملاحظة:

تعيين الحقول هي وسيطة تتكون من مجموعة من مربعات الاختيار ، على سبيل المثال ، إعداد السياسات لمجموعات المستخدمين ، “خدمة” RADIUS

ملاحظة:

سيتم تحديد القيم المفروضة على مربعات التحرير والسرد للاختيار من القائمة المنسدلة

صفحة الحالة :

ملاحظة: يؤدي بدء واجهة برمجة تطبيقات RouterOS 5.7 إلى إضافة إمكانية للمستخدمين لإنشاء صفحة حالة حيث يمكن إضافة الحقول من أي مكان وترتيبها.

يمكن إنشاء صفحة Satus بواسطة المستخدمين (مع أذونات كافية) ويمكن إعادة ترتيب الحقول على الصفحة.

عندما يتم إنشاء صفحة الحالة ، تكون الصفحة الافتراضية التي تفتح عند تسجيل الدخول في جهاز التوجيه من خلال واجهة webfig.

إضافة الحقول :

لإضافة الحقل إلى صفحة حالة المستخدم يجب إدخال وضع “Design skin” ومن القائمة المنسدلة في الحقل اختيار الخيار – “Add to status page”

ونتيجة لهذا الإجراء سيتم إضافة الحقل المطلوب في وضع القراءة فقط إلى صفحة الحالة.

إذا كانت صفحة الحالة غير موجودة في الوقت ، فسيتم إنشاؤها للمستخدم تلقائيًا.

status pageWebfig الدخول على الميكروتك

عمودين :

يمكن ترتيب الحقول في صفحة الحالة في عمودين. يتم ملء الأعمدة من الأعلى إلى الأسفل.

عندما يكون لديك عمود واحد فقط ، يجب أن يتم سحب العنصر الأول المخصص للجزء الثاني إلى الجزء العلوي من العنصر الأول عندما يظهر الخط الأسود أعلى العنصر الأول ، ثم سحب الماوس إلى اليسار حتى يتم عرض خط أسود أقصر كما هو موضح في لقطة الشاشة.

سيؤدي تحرير زر الماوس إلى إنشاء العمود الثاني.

يمكن سحب بقية الحقول بعد ذلك وإسقاطها بنفس الطريقة مع تصميم عمود واحد.

Webfig-two-columns

أمثلة Skin design :

تعيين الحقل :

Webfig-set-field-limits-designWebfig الدخول على الميكروتك

Webfig-set-field-limits-doneWebfig الدخول على الميكروتك

استخدام skins:

لاستخدام الأسطح ، يتعين عليك تعيين مظهر skins للمجموعة ، وعندما يتم ذلك ، سيستخدم مستخدمو هذه المجموعة تلقائيًا skins المحددة كإعداد افتراضي عند تسجيل الدخول إلى Webfig.

ملاحظة: Webfig هي واجهة التهيئة الوحيدة التي يمكنها استخدام الأسطح

أنتهى … Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله

اذا اعجبك الموضوع Webfig الدخول على الميكروتك باستخدام المتصفح بخاصية Webfig لادارة الشبكة ومتابعتها لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات بالمنتديات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

الراوتربورد RB2011iL-IN من مايكروتك

الراوتربورد RB2011iL-IN : لازلنا في سلسة استعراض اجهزة شركة مايكروتك Mikrotik ومواصفات هذي الاجهزة . …



Mohon Aktifkan Javascript!Enable JavaScript