البداية / مايكروتك / دمج خطوط / الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

PCC هي ميزة في Mikrotik routerOS تسمح بتقسيم traffics  إلى تدفقات متساوية من الحزم ، مما يمنح المسؤولين القدرة على تحديد والحفاظ على عمليات traffics المحددة مقيدة باتصال محدد مسبقًا.

يمكن استخدامه لتحقيق موازنة التحميل load-balancing من خلال خيار fail-over في اتصال ISP مزدوج.

في هذا المقال ، سوف نتحدث حول كيفية تكوين موازنة التحميل على جهاز توجيه Mikrotik ، باستخدام PCC.

يمكننا توجيه الاتصالات التي تأتي عبر مزود خدمة الإنترنت بالخروج عبر اتصال مزود خدمة الإنترنت نفسه.

الشرح أدناه يضمن تحقيق ذلك .

أولا ، معالجة واجهات interfaces :

الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

تعيين عناوين IP :

/ ip address

add address=172.16.10.1/24 network=172.16.10.0 broadcast=172.16.10.255
interface=LAN

add address=192.168.1.2/30 network=192.168.1.0 broadcast=192.168.1.3
interface=ISP1

add address=192.168.2.2/30 network=192.168.2.0 broadcast=192.168.2.3
interface=ISP2

تعيين القيتواي الافتراضية للاتصالات غير المميزة :

/ip route

add dst-address=0.0.0.0/0 check-gateway=ping gateway=192.168.1.1,192.168.2.1

قواعد الـ Nat   للـ traffics خارج كل من مقدمي خدمات الإنترنت :

/ip firewall nat

add action=masquerade chain=srcnat comment=”ISP1″ out-interface=ether1

add action=masquerade chain=srcnat comment=”ISP2″ out-interface=ether2

لأننا نريد التأكد من أن الاتصالات الواردة عبر مزود خدمة إنترنت واحد ، تغادر عبر نفس مزود خدمة الإنترنت ، يجب علينا تحديد هذه الاتصالات والحفاظ عليها منفصلة.

سوف نستخدم Mark in bound على الاتصالات عند وصولها عبر مزودي خدمات الإنترنت ، وسوف نستخدم Mark  out bound عند مغادرتهم.

انظر أدناه :

علامة الاتصالات الواردة :

/ip firewall mangle

add action=mark-connection chain=input comment=”ISP1_Inbound” in-interface=ether1 new-connection-mark=”ISP1_Inbound”

add action=mark-connection chain=input comment=”ISP2_Inbound” in-interface=ether2 new-connection-mark=”ISP2_Inbound”

استخدم علامة Mark outbound للاتصالات الصادرة :

add action=mark-routing chain=output comment=”ISP1­_Outbound” connection-mark=”ISP1_Inbound” new-routing-mark=”ISP1_Outbound”

 

add action=mark-routing chain=output comment=”ISP2_Outbound” connection-mark=”ISP1_Inbound” new-routing-mark=”ISP2_Outbound”

باستخدام route-mark التي تم إنشاؤها أعلاه ، نحتاج إلى تعيين العلامات التي ستحدد الاتصالات المختلفة.

سيتم تحديد الاتصالات التي تحتوي على عناوين الوجهة التي ليست من عناوين LAN بناءً على علامة المسار ، والتي تُستخدم لتصنيف النسبة التي يجب أن يتم بها إنشاء اتصالات من كلا رابطي ISP.

انظر أدناه:

تحديد route marks لاتصالات LAN :

/Ip firewall mangle

add action=mark-routing chain=prerouting comment=”LAN load balancing 2-0″ \

dst-address-type=!local in-interface=ether3 new-routing-mark=\

“ISP1_Outbound” passthrough=yes per-connection-classifier=\

both-addresses-and-ports:2/0

add action=mark-routing chain=prerouting comment=”LAN load balancing 2-1″ \

dst-address-type=!local in-interface=ether3 new-routing-mark=\

“ISP2_Outbound” passthrough=yes per-connection-classifier=\

both-addresses-and-ports:2/1

أخيرًا ، نقوم بإنشاء طرق افتراضية للاستفادة من علامات المسار أعلاه لتحقيق توازن التحميل عبر كل من موفر خدمة الإنترنت. هذه الطرق الافتراضية ستضمن أن traffics يأتون عبر مزود خدمة الإنترنت لمغادرة نفسه.

انظر أدناه:

تحديد المسارات الافتراضية

/ip route

add distance=1 gateway=192.168.1.1 routing-mark=”ISP1_Outbound”

add distance=1 gateway=192.168.2.1 routing-mark=”ISP2_Outbound”

سيضمن التكوين أعلاه أن تكون عمليات traffics غير متوازنة عبر حملتي مزودي خدمة الإنترنت عن طريق التأكد من أن الاتصال الذي يبدأ عبر مزود خدمة الإنترنت يظل مع مزود خدمة الإنترنت ما عدا فشل الرابط ، وفي هذه الحالة سيتم إعادة تأسيس الاتصال باستخدام الرابط البديل.

سوف تستفيد الاتصالات غير المميزة من أول مسار افتراضي تم تكوينه والذي يجعل ISP1 هو الاتصال المفضل بينما ISP2 هو مسار النسخ الاحتياطي.

انتهى … الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

ملاحظة :

قد تكون المقالة محمية ضد النقل وبالتالي لنسخ الاكواد ان وجدت انقر على علامة + بأعلى يمين الكود والتي تظهر عند تمرير الماوس على الكود .

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم الدمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC)

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك موضوع دمج على أجهزة Mikrotik باستخدام Per Connection Classifier (PCC) لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

سيرفر دمج مايكروتك

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية Server integration of …

تعليق واحد

  1. اخي الكريم الف شكرلك على مواضيعك المفيدة
    ارجو منك لو ساعدتني بهذا الموضوع وانا لك من الشاكرين
    لدي 3 خطوط انترنت مختلفة السرعة على كيسة كمبيوتر مايكروتيك 5.20 الانترنت يعمل وليس لدي مشكلة غير ان يعمل الدمج على خطين فقط ولا يعمل على ثلاث البورت الاول 4ميغا الثاني 12 ميغا الثالث 6 ميغا جميع الكروت الشبكة تعمل هذا هو السكربت الخاص بي ارجو المساعدة وشكرا

    /ip address
    add address=192.168.0.1/22 comment=OUT disabled=no interface=Local network=192.168.0.0
    add address=192.168.12.100/22 comment=Line1 disabled=no interface=WAN1 network=192.168.12.0
    add address=192.168.4.100/22 comment=Line2 disabled=no interface=WAN2 network=192.168.4.0
    add address=192.168.8.100/22 comment=Line3 disabled=no interface=WAN3 network=192.168.8.0

    /ip route
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.12.1 routing-mark=to_wan1 scope=30 \
    target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.4.1 routing-mark=to_wan2 scope=30 \
    target-scope=10
    add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.8.1 routing-mark=to_wan3 scope=30 \
    target-scope=10
    add check-gateway=ping disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.12.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=2 dst-address=0.0.0.0/0 gateway=192.168.4.1 scope=30 target-scope=10
    add check-gateway=ping disabled=no distance=3 dst-address=0.0.0.0/0 gateway=192.168.8.1 scope=30 target-scope=10

    /ip firewall nat
    add action=passthrough chain=unused-hs-chain comment=”place hotspot rules here” disabled=yes to-addresses=0.0.0.0
    add action=masquerade chain=srcnat disabled=no out-interface=WAN1 src-address=192.168.0.0/22
    add action=masquerade chain=srcnat disabled=no out-interface=WAN2 src-address=192.168.0.0/22
    add action=masquerade chain=srcnat disabled=no out-interface=WAN3 src-address=192.168.0.0/22
    add action=masquerade chain=srcnat comment=”masquerade hotspot network” disabled=no src-address=192.168.0.0/22 \
    to-addresses=0.0.0.0
    add action=masquerade chain=srcnat comment=”masquerade PPPoE network” disabled=no src-address=\
    192.168.16.1-192.168.16.254 to-addresses=0.0.0.0

    /ip firewall mangle
    add action=accept chain=prerouting disabled=no in-interface=WAN1
    add action=accept chain=prerouting disabled=no in-interface=WAN2
    add action=accept chain=prerouting disabled=no in-interface=WAN3
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan1_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/0 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/1 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan3_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/3 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan1_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/4 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/5 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/6 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan2_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/7 src-address=192.168.0.0/22
    add action=mark-connection chain=prerouting disabled=no dst-address-type=!local new-connection-mark=wan3_conn \
    passthrough=yes per-connection-classifier=both-addresses-and-ports:8/8 src-address=192.168.0.0/22
    add action=mark-routing chain=prerouting connection-mark=wan1_conn disabled=no new-routing-mark=to_wan1 passthrough=yes \
    src-address=192.168.0.0/22
    add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no new-routing-mark=to_wan2 passthrough=yes \
    src-address=192.168.0.0/22
    add action=mark-routing chain=prerouting connection-mark=wan2_conn disabled=no new-routing-mark=to_wan3 passthrough=yes \
    src-address=192.168.0.0/22

اترك تعليقاً



Mohon Aktifkan Javascript!Enable JavaScript