البداية / مايكروتك / رولات وسكربتات / تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة

تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة

تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة

معلومات أساسية :

المشكلة الوحيدة مع L2TP / IPSec على Mikrotik هي أنه لا توجد طريقة لتأمين خادم L2TP لعملاء IPSec فقط ، إذا كان لديك أشخاص يتواصلون من عناوين IP عامة مختلفة باستمرار.

في جدار الحماية ، يجب السماح بالوصول إلى خادم L2TP ، ولكن لا توجد أداة مطابقة لسياسة IPSec.

هنا وضعنا لكم السكربت الخاص بهذي المهمة لتأمين خادم L2TP لعملاء IPSec فقط.

ماذا سنحتاج لتكوينه ؟

تأكد من تأمين قاعدة جدار حماية خادم L2TP مع src-address-list = L2TP_Allowed.

add chain=input dst-port=1701 protocol=udp src-address-list=L2TP_Allowed

جدولة السكربت لتشغيلة كل 2 أو 3 ثوان ، ويتم تأمين خادم L2TP.

في حالة السماح بالاتصالات القائمة والمرتبطة في جدار الحماية ، سيكون خادم L2TP متاحًا طالما أن الاتصال موجود في جدول مسارات conn ، احترس من ذلك. (مهلة تدفق UDP الافتراضية هي 3 دقائق.)

السكربت المستخدم :

# ------------------- header -------------------
# Script by Tomas Kirnak, version 1.0.2
# If you use this script, or edit and
# re-use it, please keep the header intact.
#
# For more information and details about
# this script please visit the wiki page at
# http://wiki.mikrotik.com/wiki/Securing_L2TP_Server_for_IPSec
# ------------------- header -------------------
{
:local InAL 0
:local InRP 0
:local rawIp 0
:local CurrentPeerIP 0

:foreach i1 in [/ip ipsec remote-peers find] do={
  :set rawIp [/ip ipsec remote-peers get $i1 remote-address]
  
  :if ([:len [:find $rawIp ":"]] = 0) do={
    :set CurrentPeerIP $rawIp
  } else={
    :set CurrentPeerIP [:pick $rawIp 0 [:find $rawIp ":"]]
  }

  :foreach i2 in [/ip firewall address-list find list=L2TP_Allowed address=$CurrentPeerIP] do={
    :set InAL 1
  }
  if ($InAL = 0) do={/ip firewall address-list add list=L2TP_Allowed address=$CurrentPeerIP}
  :set InAL 0
}

:foreach i1 in [/ip firewall address-list find list=L2TP_Allowed] do={
  :set CurrentPeerIP [/ip firewall address-list get $i1 address]

  :foreach i2 in [/ip ipsec remote-peers find] do={
    :set rawIp [/ip ipsec remote-peers get $i2 remote-address]
	
    :if ([:len [:find $rawIp ":"]] = 0) do={
      :set CurrentPeerIP $rawIp
    } else={
      :set CurrentPeerIP [:pick $rawIp 0 [:find $rawIp ":"]]
    }
  
    :if ($CurrentPeerIP = [/ip firewall address-list get $i1 address]) do={
      :set InRP 1
	}
  }
  :if ($InRP = 0) do={/ip firewall address-list remove $i1}
  :set InRP 0
}
}

أنتهى … تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة

تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع تأمين خادم L2TP لـ IPSec في سيرفر الميكروتك للاشخاص المتصلين من عناوين ip عامة لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

adblock script mikrotik

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة لقد كنت أستخدم سكربت لمنع …



Mohon Aktifkan Javascript!Enable JavaScript