البداية / مايكروتك / رولات وسكربتات / UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

version for ROS 3.x

هذه السكربتات ترسل رسائل البريد الإلكتروني عند انقطاع التيار الكهربائي وعندما يكون جهد البطارية منخفضة ، وهو يعمل عندما يتم تثبيت حزمة UPS ، ومع APC ups لقياس التقلبات

تبدأ هذه السكربتات كل دقيقة بهذي المهام ونحتاج الى مثل هذي التنبيهات لمتابعة امور الشبكة ومعرفة مايحدث في غيابنا.

UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

الجدولة :-

/system scheduler
add comment="" disabled=no interval=1m name="ups-powermonitor" on-event=ups-powermonitor \
    start-date=jan/01/1970 start-time=00:00:00

أضف هذه السكربتات بأسم “ups-powermonitor” وتحقق من الإصدار الصحيح لجهازك .

# UPS-Script powerfail
# (c) steinmann und weidinger OEG
# www.stone-rich.at
#
# Watches ups status and sends emails on power failure and low battery.
# This script will FAIL if:
# - Policies write, test, and read are not set
# - The system name contains non-standard characters (space, /, ...)
# - The UPS is not named ups1 (fixed by adding configurable variable)
#
# This script was tested up to ROS 3.23
# user-configurable parameters below:

:local mailserver [:resolve mailserver];
:local mailfrom "[email protected]";
:local mailto "[email protected]";
:local upsName "ups1";

#
# do NOT make changes below!
#

:global flagonbatt;
:global flagbattlow;

:local battalarm 15;
:local battok 40;

:local curonbatt;
:local curcharge;

:local sysname [/system identity get name];
:local datetime "$[/system clock get date] $[/system clock get time]";

# First run? If so, we need to initialize the global flags
:if ([:typeof $flagonbatt]="nothing") do={:set flagonbatt 0}
:if ([:typeof $flagbattlow]="nothing") do={:set flagbattlow 0}

:set curonbatt false;
:set curcharge 100;
/system ups monitor [/system ups find name=$upsName] once do={
  :set curonbatt $"on-battery"; :set curcharge $"battery-charge";
}

:if (($curonbatt) && ($flagonbatt=0)) do={
  :set flagonbatt 1;
 /tool e-mail send from=$mailfrom  to=$mailto server=$mailserver subject="$sysname: Power failure!" \
    body="$sysname  is on battery since $datetime";
  :log info "Power-Fail: EMail sent to $mailto";
}

:if ((!$curonbatt) && ($flagonbatt=1)) do={
 :set flagonbatt 0;
 /tool e-mail send from=$mailfrom  to=$mailto server=$mailserver subject="$sysname: Power is back" \
    body="$sysname is back on power since $datetime";
  :log info "Power-Restore: Email sent to $mailto";
}

:if (($curcharge <= $battalarm) && ($flagbattlow=0)) do={
  :set flagbattlow 1;
  /tool e-mail send from=$mailfrom  to=$mailto server=$mailserver subject="$sysname: Low battery!" \
    body="$sysname battery is at $curcharge %! $datetime";
  :log info "Batt-Low: Email sent to $mailto";
}

:if (($curcharge >= $battok) && ($flagbattlow=1)) do={
  :set flagbattlow 0;
  /tool e-mail send from=$mailfrom  to=$mailto server=$mailserver subject="$sysname: Battery recharged" \
    body="$sysname Battery recharged to $curcharge% $datetime";
  :log info "Batt-Recharged: Email sent to $mailto";
}

version for ROS 2.9x:

# UPS-Script powerfail
# (c) steinmann und weidinger OEG
# www.stone-rich.at
#
# Watches ups status and sends emails on powerfail and battery low.
# This script will FAIL if:
# - Policies write, test, and read are not set
# - The system name contains non-standard characters (space, /, ...)
# - The UPS is not named ups1
#
# This script will not run on 3.x !!

:set mailserver [:resolve mailserver]
:set mailto "[email protected]"
:set mailfrom "[email protected]"
:set battalarm 15
:set battok 40

:set sysname [/system identity get name]
:set datetime ([/system clock get date] . " " . [/system clock get time])


# First run? If so, we need to initialize the global flags
:if (("-" . $flagonbatt)="-") do {:global flagonbatt 0}
:if (("-" . $flagbattlow)="-") do {:global flagbattlow 0}

:set curonbatt false
:set curcharge 100
/system ups monitor [/system ups find name "ups1"] once do {:set curonbatt $on-battery; :set curcharge $battery-charge}

:if (($curonbatt) && ($flagonbatt=0)) do {
  :global flagonbatt 1
  /tool e-mail send from=($mailfrom)  to=($mailto) server=($mailserver) subject=($sysname . ": Power failure!") body=($sysname . " is on battery since " . $datetime)
  :log info ("Power-Fail: EMail sent to " . $mailto)
}

:if ((!$curonbatt) && ($flagonbatt=1)) do {
 :global flagonbatt 0
  /tool e-mail send from=($mailfrom)  to=($mailto) server=($mailserver) subject=($sysname . ": Power is back") body=($sysname . " is back on power since " . $datetime)
  :log info ("Power-Restore: Email sent to " . $mailto)
}

:if (($curcharge <= $battalarm) && ($flagbattlow=0)) do {
  :global flagbattlow 1
  /tool e-mail send from=($mailfrom)  to=($mailto) server=($mailserver) subject=($sysname . ": Low battery!") body=($sysname . " battery is at " . $curcharge . "%! " . $datetime)
  :log info ("Batt-Low: Email sent to " . $mailto)
}

:if (($curcharge >= $battok) && ($flagbattlow=1)) do {
  :global flagbattlow 0
  /tool e-mail send from=($mailfrom)  to=($mailto) server=($mailserver) subject=($sysname . ": Battery recharged") body=($sysname . " Battery recharged to " . $curcharge . "% " . $datetime)
  :log info ("Batt-Recharged: Email sent to " . $mailto)
}

تنبية :

كثرة استخدامك للسكربتات قد تؤدي الى مشاكل بسيرفر الشبكة وبالتالي ليس كل شئ عليك برمجتة على شبكتك مالم تستدعي الحاجة لذلك .

تجنب التجارب على السيرفر الام وكن حريص دائما على عمل الباك اب قبل اجراء اي تغيير على السيرفر حرصا من عدم فقدانك للبيانات .

انتهى … UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع UPS scripts تلقي رسائل نصية عبر الميكروتك عند انطفاء او ضعف بطارية خازن ال ups لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

adblock script mikrotik

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة لقد كنت أستخدم سكربت لمنع …



Mohon Aktifkan Javascript!Enable JavaScript