البداية / مايكروتك / رولات وسكربتات / تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

إذا كان لديك جهاز كمبيوتر في المنزل وكنت بحاجة للاتصال به عبر RDP في أوقات عشوائية ، ولكن لا ترغب في إنفاق المال على الكهرباء اللازمة للحفاظ على تزويد جهاز الكمبيوتر بالطاقة طوال اليوم ، فإن هذا الحل هو ما كنت تبحث عنه :mrgreen: .

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة
اولا، أتحقق من وجود اتصالات جديدة لمنفذ RDP المعاد توجيهه:

/ip firewall nat add action=add-dst-to-address-list address-list=RDP250 chain=dstnat comment=HTPC dst-address=MY-PUBLIC-IP dst-port=MY-RDP-PORT in-interface=ether10 protocol=tcp to-addresses=10.0.0.250 to-ports=3389

بعد ذلك ، صنعت ‘Hairpin’ NAT حتى أتمكن من الوصول إلى جهاز الكمبيوتر الخاص بي عبر اسم مضيفي الخاص بي من أي مكان (الشبكة الداخلية والإنترنت):

/ip firewall nat add action=dst-nat chain=dstnat comment=HTPC dst-address=MY-PUBLIC-IP dst-port=MY-RDP-PORT in-interface=ether10 protocol=tcp to-addresses=10.0.0.250 to-ports=3389
/ip firewall nat add action=masquerade chain=srcnat comment="HTPC - Hairpin" dst-address=10.0.0.250 dst-port=MY-RDP-PORT out-interface=bridge1 protocol=tcp src-address=10.0.0.0/24

لذلك ، عندما حاولت الوصول إلى جهاز الكمبيوتر عن طريق برنامج RDP ، أضاف Mikrotik IP public إلى قائمة عناوين ثم تمكنت من الدخول .

لكن ماذا لو كان الكمبيوتر في وضع الاستعداد؟

لقد تم إنشاء هذا السكربت litle للتحقق من وجود أي IP على قائمة العناوين RDP250:

:foreach A in=[/ip firewall address-list find name=RDP250] do={
  if ([/ip firewall address-list get $A list]="RDP250") do={
    :log info "Sending WoL to $[/ip firewall address-list get $A address]"
    /tool wol mac=PC-MAC-ADDRESS interface=bridge1
    :log info "Removing IP $[/ip firewall address-list get $A address] from list"
    /ip firewall address-list remove $A
  }
}

وجدولتة لتشغيل هذا السكربت كل 10 ثوانٍ.

في 99 ٪ من الحالات ، اتصال العميل RDP في المحاولة الأولى ، في غضون 5 ثوان ممكنه.

السيناريو الأسوأ هو أنك ستضطر إلى محاولة الاتصال مرتين.

لاحظ أن السكربت صغير وبسيط نوعًا ما ولن يؤثر على وحدة المعالجة المركزية إلا إذا كان لديك عدد كبير من العناوين في القائمة.

لذا كن حذرا عند القيام بذلك. البديل هو الاتصال بالراوتر وإرسال حزمة دليل WoL.

لاحظ أنه ليس لدي عنوان IP ثابت على واجهة WAN الخاصة بي. بدلاً من ذلك ، أقوم بتحديث IP عبر جدولة ChangeIP النشطة بالفعل مع هذا السطر الإضافي من الكود:

/ip firewall nat set [/ip firewall nat find comment=HTPC] dst-address=[:pick $ddnsip 0 [:find $ddnsip "/"] ]

أنتهى … تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع تشغيل الشبكة المحلية LAN للكمبيوتر قبل الاتصال بسطح المكتب البعيد لادارة الشبكة لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك المشكلة : كنت ترغب …



Mohon Aktifkan Javascript!Enable JavaScript