البداية / مايكروتك / دمج خطوط / دمج خطين بطريقة PCC في سيرفر الميكروتك وموازنة الاحمال بالتساوي

دمج خطين بطريقة PCC في سيرفر الميكروتك وموازنة الاحمال بالتساوي

دمج خطين بطريقة PCC في سيرفر الميكروتك وموازنة الاحمال بالتساوي

يمتلك برنامج ميكروتك راوتر router OS اكثر ميزة مفضلة تسمى موازنة التحميل.

تعمل ميزة موازنة التحميل على توزيع عدد المستخدمين لانترنت الشبكة في اتجاهات متعددة وفقًا لحجم الـ traffic ( اي حجم البيانات ) في الوقت الفعلي.

وتستخدم التقنية الأكثر شيوعًا لتنفيذ موازنة التحميل NTH أو PCC (لكل نوع من الاتصالات).

يمكن أيضًا أن تكون طرق موازنة التحميل خيارًا بديلًا للحصول على نطاق ترددي كبير ( bandwidth  )  بسعر رخيص نسبيًا. لأنه بشكل عام ، فإن الـ traffic الأكثر طلبًا يكون اتجاه التيار 😆 (اي التنزيل نحو المستخدم) مقارنة بـ traffic  الراوتر والتي تكون أقل نسبيا.

في هذا الموضوع ، سأقوم بشرح تطبيق موازنة التحميل باستخدام طريقة PCC.

في هذا المثال ، لدينا 1 LAN متصل بالإنترنت من خلال WAN 2 من مزود خدمة إنترنت مختلف.

ISP 1 = 10.10.10.11/28
Gateway = 10.10.10.1

ISP 2 = 11.11.11.10/28
Gateway = 11.11.11.1

LAN = 192.168.1.0/24
Gateway = 192.168.1.1

دمج خطين بطريقة PCC في سيرفر الميكروتك
دمج خطين بطريقة PCC في سيرفر الميكروتك

ثم نبدأ بإنشاء عناوين IP لجميع واجهات الـ interfaces  المستخدمة على الـ router :-

/ip address
add address=10.10.10.11/28 disabled=no interface=WAN1 network=10.10.10.0
add address=11.11.11.10/28 disabled=no interface=WAN2 network=11.11.11.0
add address=192.168.1.1/24 disabled=no interface=LAN network=192.168.1.0

الان انتقل إلى IP -> Firewall -> Mangle لإنشاء إعدادات PCC Load Balancer :

/ip firewall mangle
add action=mark-connection chain=input disabled=no in-interface=WAN1 new-connection-mark=WAN1_connmark passthrough=yes
add action=mark-connection chain=input disabled=no in-interface=WAN2 new-connection-mark=WAN2_connmark passthrough=yes
add action=mark-routing chain=output connection-mark=WAN1_connmark disabled=no new-routing-mark=to_ISP1 passthrough=yes
add action=mark-routing chain=output connection-mark=WAN2_connmark disabled=no new-routing-mark=to_ISP2 passthrough=yes
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=WAN1_connmark passthrough=yes per-connection-classifier=both-addresses-and-ports:2/0
add action=mark-connection chain=prerouting disabled=no dst-address-type=!local in-interface=LAN new-connection-mark=WAN2_connmark passthrough=yes per-connection-classifier=both-addresses-and-ports:2/1
add action=mark-routing chain=prerouting connection-mark=WAN1_connmark disabled=no in-interface=LAN new-routing-mark=to_ISP1 passthrough=yes
add action=mark-routing chain=prerouting connection-mark=WAN2_connmark disabled=no in-interface=LAN new-routing-mark=to_ISP2 passthrough=yes

ثم ، لا تنس إنشاء إعدادات masquerade لترجمة العنوان المحلي إلى عنوان عام :-

/ip firewall nat
add action=masquerade chain=srcnat disabled=no out-interface=WAN1
add action=masquerade chain=srcnat disabled=no out-interface=WAN2

أخيرًا ، قم بإنشاء IP routes :-

/ip route
add distance=1 gateway=10.10.10.1 routing-mark=to_ISP1
add distance=1 gateway=11.11.11.1 routing-mark=to_ISP2
add distance=1 gateway=10.10.10.1
add distance=1 gateway=11.11.11.1

هذا هو المثال الخاص بي من الإعداد الخاص بي والذي يشير إلى أن جميع الإعدادات تعمل بشكل جيد ، لأن اختبار ping الخاص بي مر عبر عناوين الـ gateways المختلفة :-

دمج الخطوط PCC
دمج خطين بطريقة PCC في سيرفر الميكروتك

دمج خطين بطريقة PCC في سيرفر الميكروتك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

سيرفر دمج مايكروتك

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية

سيرفر دمج مايكروتك لعدد 9 خطوط جاهز للتحميل والتركيب من حضرموت التقنية Server integration of …



Mohon Aktifkan Javascript!Enable JavaScript