رول للحفاظ على بطارية المايكروتك

اخر تحديث في سبتمبر 29, 2022 بواسطة حمدي بانجار

رول للحفاظ على بطارية المايكروتك

رول للحفاظ على بطارية المايكروتك

ضع هذا الرول في قائمة النيوترمنال في الوينبوكس
:set sysname [/system identity get name]
:set datetime ([/system clock get date] . " " . [/system clock get time])

# Erster Lauf und Flags noch uninitialisiert?
:if (("-" . $flagonbatt)="-") do {:global flagonbatt 0}
:if (("-" . $flagbatlow)="-") do {:global flagbatlow 0}

:set curonbatt false
:set curbatlow false
/system ups monitor [/system ups find name "ups1"] once do {:set curonbatt $on-battery; :set curbatlow $low-battery}

:if (($curonbatt) && ($flagonbatt=0)) do {
:global flagonbatt 1
/tool e-mail send from="ups" to="somwwhere" server="1.1.1.1" subject=($sysname . " ist ohne Strom!") body=($sysname . " hat keinen Saft seit " . $datetime)
:log info "Power-Fail: Email gesendet"
}

:if ((!$curonbatt) && ($flagonbatt=1)) do {
:global flagonbatt 0
/tool e-mail send from="ups" to="somewhere" server="1.1.1.1" subject=($sysname . " hat wieder Strom") body=($sysname . " saftelt wieder seit " . $datetime)
:log info "Power-Restore: Email gesendet"
}

:if (($curbatlow) && ($flagbatlow=0)) do {
:global flagbatlow 1
/tool e-mail send from="ups" to="somewhere" server="1.1.1.1" subject=($sysname . " Batterie leer!") body=($sysname . " hat fast keine Batterie mehr - " . $datetime)
:log info "Batt-Low: Email gesendet"
}

:if ((!$curbatlow) && ($flagbatlow=1)) do {
:global flagbatlow 0
/tool e-mail send from="ups" to="somwhere" server="1.1.1.1" subject=($sysname . " Batterie nachgeladen") body=($sysname . " Battery-Low beendet - " . $datetime)
:log info "Batt-Low-Ende: Email gesendet"
}

 

رول للحفاظ على بطارية المايكروتك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم

اذا اعجبك الموضوع لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

 

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

فتح بورت في الميكروتك لتحويل طلبات منفذ معين الى جهاز داخلي ضمن شبكات الميكروتك

فتح بورت في الميكروتك لتحويل طلبات منفذ معين الى جهاز داخلي ضمن شبكات الميكروتك

اخر تحديث في سبتمبر 29, 2022 بواسطة حمدي بانجار فتح بورت في الميكروتك لتحويل طلبات …

اترك تعليقاً