البداية / مايكروتك / رولات وسكربتات / سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

سيتم استخدام هذا السكربت البرمجي بالتزامن مع خدمة DNS الديناميكية لـ DuckDNS.org.

يجب جدولتة / تشغيله على جهاز توجيه Mikrotik. بخلاف الإصدار الأصلي (انقر فوق زر MikroTik بعد تحميل الصفحة) ، لا يستخدم هذا البرنامج النصي أي متغيرات عامة ، بل إنه يقارن IP الحالي لواجهة WAN مع IP (DNS) الذي تم حله للمستخدمين DuckDNS.org’s FQDN (على سبيل المثال ، mysudbdomain.duckdns.org).

سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

ما عليك سوى إنشاء النطاق الفرعي DuckDNS.org إذا لم تكن بالفعل قد انشأته وتأكد من تحديث القيم للمتغيرات التالية: duckdnsFullDomain و duc

kdnsSubDomain و duckdnsToken و wanInterface و logDestination.

DuckDNS.org Dynamic DNS Update Script v1.0 :

#---------------------------------------------------SCRIPT INFORMATION----------------------------------------------------
#
# Script:  Marthur's DuckDNS.org Dynamic DNS Update Script
# Version: 1.0
# Updated: 10/30/2017
# Created: 10/30/2017
# Author:  Marthur Jones
# Website: https://www.hd-tch.com
#
#-----------------------------------------------TESTED USING THE FOLLOWING------------------------------------------------
#
# Hardware: CCR1009-7G-1C-1S+
# Firmware: v3.41
# RouterOS: v6.40.4
#
# This script is to be used in conjuction with DuckDNS.org's Dynamic DNS Service. It is to be scheduled/ran on a Mikrotik 
# router. Unlike the original version, this script does not use any global variables, instead it compares the current IP
# of the WAN interface with the resolved (DNS) IP of the users DuckDNS.org's FQDN (e.g. mysudbdomain.duckdns.org).
#
#----------------------------------------------MODIFY THIS SECTION AS NEEDED----------------------------------------------

# DuckDNS Full Domain (FQDN)
:local duckdnsFullDomain "mysubdomain.duckdns.org"

# DuckDNS Sub Domain
:local duckdnsSubDomain "mysubdomain"

# DuckDNS Token
:local duckdnsToken "7311de01-1830-454d-be05-9e8f2f99f4ce"

# The interface name with the assigned dynamic IP address (usually the WAN interface).
:local wanInterface "Ether0-Gateway"

# Log destination
:local logDestination "/disk1/logs/"

#-------------------------------------------------------------------------------------------------------------------------

:log warning message="START: DuckDNS.org DDNS Update"

:if ([/interface get $wanInterface value-name=running] = true) do={

#   Get the previous IP via DNS resolution.
    :local previousIP [:resolve "$duckdnsFullDomain"]

#   Get the current IP on the WAN interface.
    :local currentIP [/ip address get [find interface="$wanInterface" disabled=no] address]

#   Strip net mask from IP address.
    :for i from=([:len $currentIP] - 1) to=0 do={
        :if ([:pick $currentIP $i] = "/") do={
            :set currentIP [:pick $currentIP 0 $i]
        }
    }

    :log info "DuckDNS: DNS IP ($previousIP), interface IP ($currentIP)"
    
    :if ($currentIP != $previousIP) do={
        :log info "DuckDNS: Current IP $currentIP is not equal to previous IP, update needed"
        :log info "DuckDNS: Sending update for $hostname"
        /tool fetch mode=https keep-result=yes dst-path=($logDestination . "duckdns-ddns-update.txt") address=[:resolve www.duckdns.org] port=443 host=www.duckdns.org src-path=("/update?domains=" . $duckdnsSubDomain . "&token=" . $duckdnsToken . "&ip=" . $currentIP);
        :log info "DuckDNS: Host $hostname updated on DuckDNS with IP $currentIP"
    }   else={
        :log info "DuckDNS: Previous IP $previousIP is equal to current IP, no update needed"
        }

}   else={
    :log info "DuckDNS: $wanInterface is not currently running, unable to verify and/or update IP."
    }
    
:log warning message="END: DuckDNS.org DDNS Update"

انتهى … سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم سكرببت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع

وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع سكربت التحديث التلقائي لخدمات DuckDNS.org DDNS للميكروتك لاتبخل علينا بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك

كيفية استخدام أسماء المضيفين في قواعد جدار الحماية في سيرفر الميكروتك المشكلة : كنت ترغب …

اترك تعليقاً



Mohon Aktifkan Javascript!Enable JavaScript