البداية / مايكروتك / امن وحماية / كيفية حظر مواقع ويب للبالغين باستخدام OPENDNS مجانًا -مع دعم تصفية الفئات الأساسية

كيفية حظر مواقع ويب للبالغين باستخدام OPENDNS مجانًا -مع دعم تصفية الفئات الأساسية

كيفية حظر مواقع ويب للبالغين باستخدام OPENDNS مجانًا -مع دعم تصفية الفئات الأساسية

آخر يوم سألني أحدهم عن كيفية حظر مواقع البالغين في mikrotik. لا توجد طريقة مبنية للقيام بذلك لأنها تنطوي على تصفية عناوين URL وليس مهمة ROUTER للقيام بمثل هذه المهمة.

يمكن للـ proxy server المخصص القيام بذلك بشكل فعال نظرًا لأنه تم تصميمه لمثل هذه الأغراض مثل :

التخزين المؤقت / تصفية عناوين URL / إعادة التوجيه وما إلى ذلك.
يستخدم Microsoft TMG في المؤسسات والتي تقوم بتصفية عناوين URL استنادًا إلى الفئة ، لذلك يسهل علينا فقط تحديد الفئة المطلوبة التي نرغب في منعها ، على سبيل المثال Porn / Gambling / Spywares etc ولكن Microsoft تفرض رسومًا على هذه الخدمة على أساس سنوي ( وهو ما أعتقد أنه حوالي 15 دولارًا لكل مستخدم سنويًا) ، وهو يقوم بالمهمة على أكمل وجه وبكفاءة عالية ، ولكنه ليس حلاً فعالًا من حيث التكلفة خصوصًا إذا لم يكن لديك ميزانية كافية للدفع لشركة Microsoft.

ومع ذلك ، فإن الطريقة التالية هي الطريقة الحرة والأنيقة والنظيفة لحجب 99 دولارًا تقريبًا من مواقع الويب الإباحية باستخدام خادم OpenDNS كخادم DNS الأساسي في server / router أو حتى الكمبيوتر المكتبي.

استخدم ملقم DNS أدناه كخادم نظام أسماء النطاقات الأساسي في خادم / جهاز التوجيه mikrotik / server أو حتى سطح المكتب. إذا كنت تستخدم Mikrotik أو خادم آخر ، تأكد من أن العملاء يستخدمون خادم IP الخاص بك كما يوجد خادم DNS ، لأن opendns ستعمل فقط إذا كان client / router يستخدم خادم DNS هناك. يمكنك أيضًا إجبار المستخدمين على استخدام خادم DNS الخاص بك عن طريق إضافة rule إعادة التوجيه بحيث يجب إعادة توجيه كل طلب لنظام أسماء النطاقات إلى خادمك المحلي.

208.67.222.123
208.67.220.123

إذا كنت تستخدم خادم mikrotik ، فإنه سيبدو كم بالصورة ادناه :

الآن إذا حاولت فتح أي موقع ويب خاص بالبالغين ، فلن تفتحه وستعطيك خطأ في المتصفح الافتراضي “تعذر الفتح”

أو ستتم إعادة توجيه الطلب إلى صفحة OpenDNS لإعلامك بأن الطلب تم حظره بواسطة OpenDNS.

كما هو موضح في الصورة أدناه. . .

Block website

يمكنك أيضًا عرض صفحتك الخاصة موضحة أن مواقع الويب للبالغين محظورة ومع إعلانك.

لهذا الغرض ، عليك تمكين web.proxy وإعادة توجيه حركة المستخدم إلى الوكيل المحلي ، ثم في وصول الوكيل ، حظر http://www.blocked-website.com / block.opendns.com وإعادة توجيهها إلى خادم الويب المحلي .

تصفية قاعدة التصنيف …

إذا كان لديك عنوان IP عام ، فيمكنك إنشاء حساب على http://www.opendns.com ومن ثم يمكنك إجراء تصفية أساسية للفئات.

كما هو موضح في الصورة أدناه …

OpenDns

حضر مواقع الويب للبالغين عبر OpenDns

كيفية تمكين Web Proxy في Mikrotik وإعادة توجيه صفحة الخطأ opendns إلى صفحة الخطأ المحلية.

/ip proxy
set always-from-cache=no cache-administrator=webmaster cache-hit-dscp=4 \
cache-on-disk=no enabled=yes max-cache-size=none max-client-connections=\
600 max-fresh-time=3d max-server-connections=600 parent-proxy=0.0.0.0 \
parent-proxy-port=0 port=8080 serialize-connections=no src-address=\
0.0.0.0
 
/ip proxy access
add action=deny disabled=no dst-host=www.blocked-website.com dst-port="" \
redirect-to=101.11.11.240/nonpayment/nonpayment.htm</pre>
 
/ip proxy access
add action=deny disabled=no dst-host=opendns.blockdns.com dst-port="" \
redirect-to=101.11.11.240/nonpayment/nonpayment.htm

استبدل الرقم 101.11.11.240 والمسار الكامل بخادم الويب المحلي الخاص بك.

الآن تمكين قاعدة NAT لإعادة توجيه حركة المستخدم إلى الوكيل المحلي.

الآن إعادة توجيه كافة حركة المستخدم إلى الوكيل المحلي

/ip firewall nat
 add action=redirect chain=dstnat disabled=no dst-port=80 protocol=tcp \
 to-ports=8080

تأكد من نقل هذه القاعدة في قسم NAT أعلى قاعدة الافتتاحية الافتراضية.

لذلك يلتقط حركة مرور HTTP ويعيد توجيهها ، قبل أن يتخيلها للعالم الخارجي.

كما هو موضح في الصورة أدناه. . .

nat

إذا كنت لا تريد استخدام الخادم proxy لجميع الطلبات ، ولكن فقط http://www.blocked-website.com ، فاستخدم الـ rule أدناه التي سيؤدي فقط إلى إعادة توجيه حركة المرور المحظورة – web.com إلى بروكسي الويب المحلي ، وستكون جميع الزيارات الأخرى تذهب مباشرة إلية.

/ip firewall nat
add action=redirect chain=dstnat disabled=no dst-address=208.69.33.135 \
dst-port=80 protocol=tcp to-ports=8080

الآن عندما يحاول المستخدم فتح أي موقع ويب خاص بالبالغين ، سيتم إعادة توجيهه إلى الوكيل المحلي ، وسيقوم الوكيل (باستخدام قواعد الوصول التي قمنا بتعريفها أعلاه) بإعادة توجيه الطلب إلى صفحة خادم الويب المحلية الخاصة بنا التي تعرض صفحة المعلومات الخاصة بنا.
كما هو موضح في الصورة أدناه. . .

info-page

كيفية إجبار المستخدمين على استخدام ملقم DNS محدد

/ip firewall nat
add chain=dstnat action=dst-nat to-addresses=192.168.1.1 to-ports=53 protocol=tcp dst-port=53
add chain=dstnat action=dst-nat to-addresses=192.168.1.1 to-ports=53 protocol=udp dst-port=53

أنتهى … كيفية حظر مواقع ويب للبالغين باستخدام OPENDNS مجانًا -مع دعم تصفية الفئات الأساسية

كيفية حظر مواقع ويب للبالغين باستخدام OPENDNS مجانًا -مع دعم تصفية الفئات الأساسية

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم والذي نتمنى ان ينال رضاكم واعجابكم

والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

Winbox Blocked Mikrotik

كيف تمنع ظهور ماك السيرفر من خارج الشبكة عند استخدام الوينبوكس من قبل المخترقين

كيف تمنع ظهور ماك السيرفر من خارج الشبكة عند استخدام الوينبوكس من قبل المخترقين Winbox …



Mohon Aktifkan Javascript!Enable JavaScript