البداية / مايكروتك / امن وحماية / منع دخول المخترقين Brute force باستخدام سيرفر الميكروتك mikrotik

منع دخول المخترقين Brute force باستخدام سيرفر الميكروتك mikrotik

منع دخول المخترقين Brute force attacks باستخدام سيرفر الميكروتك mikrotik

في آخر موضوع لنا ، تحدثنا عن حظر مسح المنفاذ للسيرفر من قبل المخترقين .

واليوم سنتحدث عن هجوم Brute force attacks فما المقصود بهذا المصطلح وماهو نوعية هذا الهجوم وكيف يتم ؟

ما هو Brute force attacks ؟


لا يحاول هجوم Brute Force فك تشفير أي معلومات ، ولكن يستمر في تجربة قائمة بكلمات مرور أو كلمات أو أحرف مختلفة يتم حفظها في ملف يسمى “dictionary”.

يحتوي هذا القاموس على الآلاف من اسم المستخدم وكلمة مرور المحتملة والشائعة المستخدمة من قبل الناس على سبيل المثال. mypassword ، 123321 ، 11oct1990 ، إلخ.

يتضمن هجوم Brute Force او بما يسمى القوة الغامضة الأكثر تعقيداً على :

محاولة تجربة كل المفاتيح حتى يتم العثور على كلمة المرور الصحيحة.

نظرًا لعدد المجموعات الممكنة من الأحرف والأرقام والرموز ، يمكن أن يستغرق هجوم Brute force attacks وقتًا طويلاً حتى يكتمل. كلما زاد نوع التشفير المستخدم (تشفير 64 بت أو 128 بت أو 256 بت) ، يمكن أن يكون أطول .

منع دخول المخترقين Brute force
منع دخول المخترقين Brute force

كيف نمنعها؟


للمساعدة على منع هجمات Brute force attacks في العديد من الأنظمة :

فلا تسمح العديد من الأنظمة للمستخدم إلا بإدخال خطأ عن طريق إدخال اسم المستخدم أو كلمة المرور ثلاث أو أربع مرات.

إذا تجاوز المستخدم هذه المحاولات ، فسيقوم النظام إما بإغلاقها خارج النظام أو منع أي محاولات مستقبلية لفترة محددة من الوقت.

لذلك ، أنا اتحدث عن منع هجوم Brute force attacks في ميكروتيك لأنه يسمح لنا بإنشاء أعداد لمنع المستخدم الذي يرتكب خطأ عند إدخال اسم المستخدم وكلمة المرور الخاصة به.
هذه الصورة أدناه كمثال على من يهاجم شبكة باستخدام هجوم Brute force attacks SSH :-

brute-force-ssh
brute-force-ssh

لذلك ، استخدم هذا الرول لحظر المستخدم الذي يحاول اختراق شبكتك:

/ip firewall filter
add chain=input protocol=tcp dst-port=21-23 src-address-list=blacklist-address action=drop comment="TELNET FTP SSH Bruteforce Filter"
add chain=input protocol=tcp dst-port=21-23 connection-state=new src-address-list=stage-3 action=add-src-to-address-list address-list=blacklist-address address-list-timeout=10d
add chain=input protocol=tcp dst-port=21-23 connection-state=new src-address-list=stage-2 action=add-src-to-address-list address-list=stage-3 address-list-timeout=1m
add chain=input protocol=tcp dst-port=21-23 connection-state=new src-address-list=stage-1 action=add-src-to-address-list address-list=stage-2 address-list-timeout=1m
add chain=input protocol=tcp dst-port=21-23 connection-state=new action=add-src-to-address-list address-list=stage-1 address-list-timeout=1m

الرول اعلاة  سيعطي المستخدم 3 محاولات لتسجيل الدخول باستخدام اسم المستخدم وكلمة المرور الصحيحين. إذا أدخل المستخدم حساب تسجيل دخول خاطئ ، فسيتم وضعه في القائمة السوداء لمدة دقيقة واحدة.

يمكنك تغيير الوقت في القائمة السوداء مع تغيير عنوان القائمة-المهلة = 1 . يمكنك أيضًا تغيير أو إضافة رقم منفذ آخر وهو رقم المنفذ المهم / المقيّد في dst-port = 21-23.

ثم ، هذه هي النتيجة :-

black listed-mikrotik
منع دخول المخترقين Brute force

منع دخول المخترقين Brute force

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتةحضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

Vlan mikrotik

Guest – VLAN – WiFi كيفية اعداد Guest VLAN WiFi في الميكروتك لحمايتة من الاختراقات

Guest – VLAN – WiFi كيفية اعداد Guest (VLAN) WiFi في الميكروتك لحمايتة من الاختراقات …



Mohon Aktifkan Javascript!Enable JavaScript