البداية / مايكروتك / رولات وسكربتات / Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

لقد كنت أستخدم سكربت لمنع الإعلانات من الظهور عبر جهاز الراوتر الخاص بي من ميكروتك مباشرة ، ولكن للأسف انتهت صلاحية النطاق المستخدم في السكربت ، لذلك قررت إنشاء القائمة بنفسي.

أستخدم نموذج شفرة php هنا: https://github.com/tarampampam/mikrotik-hosts-parser/
أولا وقبل كل شي أن هذا السكربت سيستخدم حوالي 50 ميغابايت من ذاكرة الوصول العشوائي.

تحرير:

يعمل هذا السكربت فقط على الأجهزة التي لا يقل حجمها عن 128 ميغابايت من ذاكرة الوصول العشوائي ، وللأجهزة التي تحتوي على 64 ميغابايت مثل RB751G-2HnD يمكنك استخدام الإصدار البسيط مع حوالي 3000 إدخال من هنا.

لإعداد حظر الإعلانات ، اتبع الخطوات التالية:

  • ضبط الراوتر كـ DNS server:

    Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

  • فرض طلب DNS ليتم توجيهه إلى جهاز الراوتر :

    /ip firewall nat
     add action=redirect chain=dstnat dst-port=53 in-interface=bridge protocol=udp

     

  • إضافة السكربت لاستيراد قائمة DNS الثابتة والمجدول لتحديث القائمة في اليوم مره :

    /system script
     add name=adblock policy=\
     ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon source=":\
     log warning \"starting adblock update\";\r\
     \n\
     \n\
     \n:delay 20;\r\
     \n\
     \n\
     \n:log warning \"downloading adblock\";\r\
     \n\
     \n\
     \n\
     \n\
     \n:local hostScriptUrl \"https://www.micu.eu/adblock/adblock.php\";\
     \n\
     \n\
     \n\
     \n\r\
     \n:local scriptName \"adblock\";\
     \n\
     \n\
     \n\
     \n\r\
     \ndo {\
     \n\
     \n /tool fetch mode=http url=\$hostScriptUrl dst-path=(\"./\".\$scriptName\
     );\
     \n\
     \n\r\
     \n:delay 20;\
     \n\
     \n\r\
     \n:if ([:len [/file find name=\$scriptName]] > 0) do={\r\
     \n\
     \n\
     \n :log warning \"removing old adblock list\";\
     \n\
     \n\r\
     \n /ip dns static remove [/ip dns static find address=127.0.0.1];\
     \n\
     \n\r\
     \n :log warning \"importing new adblock list\";\r\
     \n\
     \n\
     \n /import file-name=\$scriptName;\r\
     \n\
     \n\
     \n /file remove \$scriptName;\r\
     \n\
     \n\
     \n :log warning \"adblock list imported\";\r\
     \n\
     \n\
     \n } else={\
     \n\
     \n \r\
     \n:log warning \"adblock list not downloaded, script stopped\";\r\
     \n\
     \n\
     \n }\r\
     \n\
     \n\
     \n} on-error={\
     \n\
     \n \r\
     \n:log warning \"adblock list download FAILED\";\
     \n\
     \n\r\
     \n};"
     /system scheduler
     add interval=1d name=adblock on-event=adblock policy=\
     ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
     start-time=startup
     add name=adblock_startup on-event=\
     ":delay 30;\r\
     \n/system script run adblock" policy=\
     ftp,reboot,read,write,policy,test,password,sniff,sensitive,romon \
     start-time=startup

     

وبهذا فأن الاعلانات لدى زوار شبكتك ستصبح محجوبة تماما ولاكن سيواجة عملائك مشكلة بعض المواقع التي عملت اضافة برمجية لمواقعهم بعدم السماح بتصفح الموقع حتى يتم السماح بمشاهدة الاعلانات .

أنتهى … Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

والذي نتمنى ان ينال رضاكم واعجابكم والى اللقاء في موضوع جديد شيق ورائع وحتى ذلك الحين لاتنسو الاهتمام بصحتكم وحفظكم الله …

اذا اعجبك الموضوع Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة  … حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

الحصول على IP Range معين للمتصلين

الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين

الاتصال PPPoE حتى يتم الحصول على IP Range معين للمتصلين هذا السكربت مخصص لأولئك الذين …

اترك تعليقاً



Mohon Aktifkan Javascript!Enable JavaScript