البداية / مايكروتك / رولات وسكربتات / إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

تحدث مشكلات كثيرة في سيرفر الميكروتك نظرا لاستخدام العديد من السكربتات المكرره او المتشابهة الوظيفة لذلك :

يمكن تشغيل البرنامج النصي التالي في terminal

(أو عبر أي أداة أتمتة يمكنها تسجيل الدخول إلى أجهزة MikroTik عبر SSH) والتحقق من أي “وظيفة” نصية مكررة وايقافها فورا.

إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

لهذا كتبت هذا بعد أن لاحظت أن بعضًا من السكربتات التي تستخدم الجلب ستعلق بشكل دوري وتترك وظائف متعددة مفتوحة.

#kill duplicate script jobs
:global counter
:global counter2
:foreach counter in=[/system script job find] do={
:global job [/system script job get $counter script] :if ([:len [/system script job find where script=$"job"]] > 0 && [:len $job] > 0) do={
:put "Duplicate script running: $job - terminating all"
:foreach counter2 in=[/system script job find where script=$"job"] do={
/system script job remove $counter2
}
}
}

حل واحد لمنع هذا على مستوى الجدولة ( scheduler  ) هو إنشاء التحقق في بداية إدخال جدولة جديدة لضمان تشغيل مثيل واحد فقط من هذا البرنامج النصي .

ويمكن تحقيق ذلك عن طريق إضافة هذه الكتلة البرمجية قبل تشغيل برنامج نصي في إدخال الجدولة الخاصة بك:

:global scriptname "YOURSCRIPTNAME"
:if ([:len [/system script job find script=$"scriptname"]] > 0) do={
:log info "$scriptname Already Running - killing old script before continuing"
:foreach counter in=[/system script job find script=$"scriptname"] do={
/system script job remove $counter
}
}
/system script run $scriptname

أنتهى … إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

الى هنا نكون وصلنا الى نهاية موضوعنا اليوم بعنوان إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

اذا اعجبك الموضوع إيقاف السكربتات المجدولة في MikroTik إذا تم الكشف عن مثيلات متعددة لها

لاتنسى ان تقوم بمشاركتة على مواقع التواصل الاجتماعي ليستفيذ منه الغير,كما نتمنى اشتراككم في قناة الموقع على اليوتيوب بالضغط هنا وكذلك الاشتراك في مجموعة الفيس بوك بالضغط هنا والتيليقرام بالضغط هنا  وكذلك التسجيل بالموقع لتتمكنو من تحميل بعض الملفات الخاصة بالأعضاء كما يمكنكم رفع ملفاتكم مجانا على مركز ملفات حضرموت التقنية بالضغط هنا ولاتترددو في وضع أي استفسارات للرد عليكم .

دمتم بكل ود والسلام عليكم ورحمة الله وبركاتة… حضرموت التقنية

حول حمدي بانجار

باحث ومهندس في مجالات شبكات ومقاهي الأنترنت - شغوف في عالم الانترنت والبرمجة للشبكات - في حضرموت التقنية شعارنا الدائم - أفعل الخير مهما أستصغرتة ! فأنك لاتدري اي عمل يدخلك الجنة ... فلا يفلح كاتم العلم ...طموحاتي ان يصبح الموقع مدرسة تعليمية للعلوم التقنية الجديدة ومساعدة الاخرين في حل مشكلاتهم ونرحب بمن يرغب الانظمام لنا يفيذ ويستفيذ ليكبر هذا الصرح التعليمي ويحقق الاستفاذة القصوى للغير ... أنظمامكم لأسرة الموقع وقناتها ومشاركتكم بالمواضيع الهادفه هو بحد ذاتة تشجيع لنا وللغير لاستمرارية هذا الصرح التعليمي

تحقق أيضا

adblock script mikrotik

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة

Mikrotik adblock script سكربت منع الاعلانات على شبكات الميكروتك مباشرة لقد كنت أستخدم سكربت لمنع …

اترك تعليقاً



Mohon Aktifkan Javascript!Enable JavaScript